Skip site navigation (1) Skip section navigation (2)

Re: Complete breakdown of pgadmin when trying to connect to server or modify properties of tables of views

From: Michael Eschweiler <Michael(dot)Eschweiler(at)t-online(dot)de>
To: "Dave Page" <dpage(at)pgadmin(dot)org>, Pgadmin-Support <pgadmin-support(at)postgresql(dot)org>
Subject: Re: Complete breakdown of pgadmin when trying to connect to server or modify properties of tables of views
Date: 2008-03-11 14:10:47
Message-ID: 200803111510.48094.Michael.Eschweiler@t-online.de (view raw or flat)
Thread:
Lists: pgadmin-support
First I tried once more with 

> ./configure --with-pgsql=/usr --with-wx=/usr/local

but configure now stops with:

checking for strchr... yes
checking for PQexec in libpq.a... present
checking for SSL_connect in libpq.a... present
checking for krb5_free_principal in libpq.a... present
checking libpq-fe.h usability... yes
checking libpq-fe.h presence... yes
checking for libpq-fe.h... yes
checking PostgreSQL in /usr... ok
checking for PQgetOutResult in libpq.a... not present
checking wxWidgets version... ok
checking wxWidgets in /usr/local... failed
configure: error: Your wxWidgets installation cannot support pgAdmin in the 
sele
cted configuration. This may be because it was configured without 
the --enable-u
nicode option, or the combination of dynamic/static linking and 
debug/non-debug
libraries selected did not match any installed wxWidgets libraries.
error: Bad exit status from /var/tmp/rpm-tmp.39796 (%build)
>
> If it still cannot find PostgreSQL (or wxWidgets), perhaps you need to
> install some -dev packages to get the headers and libraries?

I compiled the wxWidgets with the -enable-unicode option. Therefore I followed 
your advice and controlled if the devel packages are installed.
The postgresql- and gtk2-devels are installed but as I compiled the wxWidget 
from the tarball I think the sources of this package are not (and I didn't 
install the devel from the distribution because I suppose that there would be 
some considerable differences). 
As I don't know how to install sources from a tarball I tried to create a 
source.rpm in order to install it but then configure complained:

error: Failed build dependencies: gtk+-2.0-devel is needed by 
wx-gtk2-unicode-2.8.7-0.i586

although gtk2-devel is installed. Sorry, but I must confess that this is going 
beyond my installation-skills...
>
> Of course an easier option would be to use Redhat or CentOS :-p
For pgadmin I suppose this is right, but recently I tried Fedora 8 and for 
other purposes I found some inconveniences so I decided to stick to OSS...
I never tried seriously other distributions because of lack of time. 
Michael

In response to

Responses

pgadmin-support by date

Next:From: Dave PageDate: 2008-03-11 18:31:07
Subject: Re: Complete breakdown of pgadmin when trying to connect to server or modify properties of tables of views
Previous:From: Dave PageDate: 2008-03-11 09:09:12
Subject: Re: Adding columns NOT NULL

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group