Skip site navigation (1) Skip section navigation (2)

Build and other trouble with 08.03.0100 on Linux

From: Peter Eisentraut <peter_e(at)gmx(dot)net>
To: pgsql-odbc(at)postgresql(dot)org
Subject: Build and other trouble with 08.03.0100 on Linux
Date: 2008-03-04 17:56:36
Message-ID: 200803041856.37259.peter_e@gmx.net (view raw or flat)
Thread:
Lists: pgsql-odbc
The build process of psqlodbc 08.03.0100 on Linux (or Unix platforms) seems to 
have some open ends.  The default build uses SSL but doesn't link against any 
SSL library.  Not sure how relevant that is.  But I tried disabling the SSL 
support using the advertised option --disable-openssl, which doesn't work 
because the actual option is --disable-usessl.  (Side note: If you want to 
fix the option name, it might be nice to use --without-openssl to be 
consistent with PostgreSQL.)  That build then fails because NOT_USE_LIBPQ 
must be defined.  With a successful build I experience various kinds of 
problems building up a connection, some of which even go away for a while 
when I try to connect a few times (!!!).  The driver version 08.01.0200 I 
have lying around works without problems on the identical configuration 
(odbcinst.init and odbc.ini).  Is anyone successfully using psqlodbc 
08.03.0100 on Unix platforms?

Responses

pgsql-odbc by date

Next:From: Bruce McAlisterDate: 2008-03-04 21:41:42
Subject: Re: Build and other trouble with 08.03.0100 on Linux
Previous:From: Son OsirisDate: 2008-03-04 15:09:59
Subject: Re: Symbol files

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group