Skip site navigation (1) Skip section navigation (2)

Re: reindexing

From: "Joshua D(dot) Drake" <jd(at)commandprompt(dot)com>
To: Lew <lew(at)lwsc(dot)ehost-services(dot)com>
Cc: pgsql-general(at)postgresql(dot)org
Subject: Re: reindexing
Date: 2008-02-27 19:08:45
Message-ID: 20080227110845.5308ec0a@commandprompt.com (view raw or flat)
Thread:
Lists: pgsql-general
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wed, 27 Feb 2008 11:28:32 -0500
Lew <lew(at)lwsc(dot)ehost-services(dot)com> wrote:

> In my experience at various "big-iron" shops (government agencies,
> large health-care organizations and the like), four years is not a
> long time for enterprise software - a version often has to be at
> least four years old before the powers-that-be decide to try it.  One
> has only to look at how many organizations still use Oracle 8, or
> Java 1.3, for example, to see how conservative many shops are with
> respect to upgrades.

Yes but Tom wasn't talking about upgrades. He was talking about
maintenance. You can bet that any respectable enterprise shop is at
least running the latest service packs for the respective releases. The
community does support 7.4 still. However the version that is supported
is service release (or service pack) 19. Thus 7.4.19.

> 
> I'm not saying they should be that conservative, but many
> organizations are and we must be ready to deal with that.
> 

And we already do, far more than we should IMO. This idea that the
volunteer community should somehow provide enterprise class support is
a non starter. That is what the companies surrounding the community
are for. If companies want the community and not the companies
surrounding the community to provide that kind of support, those
companies need to start paying for it.


Sincerely,

Joshua D. Drake
- -- 
The PostgreSQL Company since 1997: http://www.commandprompt.com/ 
PostgreSQL Community Conference: http://www.postgresqlconference.org/
Donate to the PostgreSQL Project: http://www.postgresql.org/about/donate
PostgreSQL SPI Liaison | SPI Director |  PostgreSQL political pundit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHxbU/ATb/zqfZUUQRAt1hAJ9NCAK6xTQtF6hcI95rwolqlNpXoACdHIoJ
IVfVRiN5PTpwxAWH6ohY1us=
=L7ov
-----END PGP SIGNATURE-----

In response to

pgsql-general by date

Next:From: Andrej Ricnik-BayDate: 2008-02-27 19:34:43
Subject: Re: Trouble running PostgreSQL server / Server must be started under certain locale.
Previous:From: Ray StellDate: 2008-02-27 18:56:35
Subject: RHEL3 configure ssl

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group