Skip site navigation (1) Skip section navigation (2)

Required make version

From: Peter Eisentraut <peter_e(at)gmx(dot)net>
To: pgsql-hackers(at)postgresql(dot)org
Subject: Required make version
Date: 2008-02-26 21:13:57
Message-ID: 200802262213.58075.peter_e@gmx.net (view raw or flat)
Thread:
Lists: pgsql-hackers
There is a build farm failure now because (apparently) an old make version:

http://buildfarm.postgresql.org/cgi-bin/show_log.pl?nm=dawn_bat&dt=2008-02-26%2019:00:01

The new amended backend linking code needs GNU make 3.80, released 2002-10-03.  
Should we just require that?  I think the PARTIAL_LINKING code path should 
still work without it.

Btw., the previously required version was GNU make 3.78, released 1999-09-22.  
This requirement has (implicitly) existed for quite a while.

Comments?

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

Responses

pgsql-hackers by date

Next:From: Robert LorDate: 2008-02-26 21:48:28
Subject: Re: Proposed changes to DTrace probe implementation
Previous:From: Robert TreatDate: 2008-02-26 20:43:40
Subject: Re: Including PL/PgSQL by default

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group