Tom Lane wrote:
> Alvaro Herrera <alvherre(at)commandprompt(dot)com> writes:
> > Simon Riggs wrote:
> >> Methinks it should be: stats_<something>, so that people find it in the
> >> same place as stats_query_string, which is still there.
> > Hum, but the order in postgresql.conf is arbitrary, right?
> I concur with Simon that it should have some relationship to
> stats_query_string. However, stats_collection doesn't appeal to me
> because that sounds like it would subsume stats_query_string (it seems
> like a master control toggle, as stats_start_collector used to be).
> Maybe something like stats_count_events?
stats_enable_counters, or just stats_counters?
We should prefix it with "stats". I understand the verb issue, but
putting the same prefix for the same module is more important ---
effectively it is stats.collection. Someday we might even use dots so
we can have multiple levels of detail, e.g. stats.block.accumulate or
something like that.
Bruce Momjian <bruce(at)momjian(dot)us> http://momjian.us
+ If your life is a hard drive, Christ can be your backup. +
In response to
pgsql-hackers by date
|Next:||From: Bruce Momjian||Date: 2007-07-31 19:52:49|
|Subject: Re: feature suggestion|
|Previous:||From: Rafael Azevedo||Date: 2007-07-31 19:33:28|
|Subject: feature suggestion|