Skip site navigation (1) Skip section navigation (2)

pgsql: Add 'volatile' to suppress 'variable might be clobbered by

From: tgl(at)postgresql(dot)org (Tom Lane)
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: Add 'volatile' to suppress 'variable might be clobbered by
Date: 2007-07-01 02:20:59
Message-ID: 20070701022059.9ECC79FB380@postgresql.org (view raw or flat)
Thread:
Lists: pgsql-committers
Log Message:
-----------
Add 'volatile' to suppress 'variable might be clobbered by longjmp'
warning emitted by some versions of gcc.

Modified Files:
--------------
    pgsql/src/backend/postmaster:
        autovacuum.c (r1.53 -> r1.54)
        (http://developer.postgresql.org/cvsweb.cgi/pgsql/src/backend/postmaster/autovacuum.c.diff?r1=1.53&r2=1.54)

pgsql-committers by date

Next:From: Tom LaneDate: 2007-07-01 02:22:23
Subject: pgsql: Fix comments not updated in recent patch.
Previous:From: Tom LaneDate: 2007-06-30 19:12:04
Subject: pgsql: Improve logging of checkpoints.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group