Skip site navigation (1) Skip section navigation (2)

Re: guid/uuid datatype

From: Bruce Momjian <bruce(at)momjian(dot)us>
To: Neil Conway <neilc(at)samurai(dot)com>
Cc: Gevik Babakhani <pgdev(at)xs4all(dot)nl>, pgsql-patches <pgsql-patches(at)postgresql(dot)org>
Subject: Re: guid/uuid datatype
Date: 2007-01-20 00:19:15
Message-ID: (view raw or whole thread)
Lists: pgsql-patches
Neil Conway wrote:
> On Sat, 2007-01-20 at 00:21 +0100, Gevik Babakhani wrote:
> > AFAIK, It is/was part of the TODO for the core.
> Well, I don't have a strong opinion either way, but I think it should be
> given some thought.
> As far as the code, looks pretty good. A few minor comments:
> * varchar_uuid() should be named uuid_varchar(), for consistency with
> the other function names. In fact, uuid_text() and varchar_uuid() are
> essentially identical, so they should be refactored. The fmgr interface
> macros can stay, I guess.
> * most of uuid.h can be gotten rid of: the SQL-callable functions are
> already declared in builtins.h, and most of the other declarations
> should be moved to uuid.c and made local to that file.
> * needs documentation

I think having it in core makes the most sense.

  Bruce Momjian   bruce(at)momjian(dot)us

  + If your life is a hard drive, Christ can be your backup. +

In response to


pgsql-patches by date

Next:From: Neil ConwayDate: 2007-01-20 00:53:40
Subject: Re: guid/uuid datatype
Previous:From: Neil ConwayDate: 2007-01-20 00:18:08
Subject: Re: guid/uuid datatype

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group