Skip site navigation (1) Skip section navigation (2)

Re: Problem configuring PostgreSQL 8.1.4 on Mac OS X

From: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
To: Adam <adam(at)albedo(dot)art(dot)pl>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: Problem configuring PostgreSQL 8.1.4 on Mac OS X
Date: 2006-06-07 13:22:54
Message-ID: 200606071322.k57DMsq02809@candle.pha.pa.us (view raw or flat)
Thread:
Lists: pgsql-bugs
Adam wrote:
> Greetings,
> 
> There is a problem with PostgreSQL 8.1.4 on Mac OS X (PowerPC).
> 
> The 'configure --enable-thread-safety' script fails when CFLAGS  
> contain "-mcpu=7400", "-mcpu=970" or "-maltivec". With these flags,  
> the GCC compiler enables AltiVec instructions for the PowerPC  
> processor, and defines:
> 
> #define __ALTIVEC__ 1
> #define __VEC__ 10206
> #define __vector __attribute__((altivec(vector__)))
> #define __pixel __attribute__((altivec(pixel__))) unsigned short
> #define __bool __attribute__((altivec(bool__))) unsigned
> #define vector vector
> #define pixel pixel
> #define _Bool _Bool
> #define bool bool
> 
> src/tools/thread/thread_test.c, fired for '--enable-thread-safety',  
> failes for not having the correct definition for 'bool'.
> 
> I would suggest using 'BOOL' for you boolean variables, instead of  
> 'bool'.
> 
> Please, fix. :)

Uh, thread_safety is only the first test that uses 'bool'.  The entire
backend uses it.  What is:

	#define bool bool

supposed to accomplish?  I suggest you avoid AltiVec until the vendor
fixes the includes.

-- 
  Bruce Momjian   http://candle.pha.pa.us
  EnterpriseDB    http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

In response to

pgsql-bugs by date

Next:From: Tom LaneDate: 2006-06-07 14:20:18
Subject: Re: Problem configuring PostgreSQL 8.1.4 on Mac OS X
Previous:From: Bruce MomjianDate: 2006-06-07 13:13:15
Subject: Re: reindexdb command utlility

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group