Skip site navigation (1) Skip section navigation (2)

BUG #2271: no privilege to install

From: "Peter laursen" <deepeter(at)snaps(dot)dk>
To: pgsql-bugs(at)postgresql(dot)org
Subject: BUG #2271: no privilege to install
Date: 2006-02-18 12:05:25
Message-ID: 20060218120525.B5125F0B06@svr2.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-bugs
The following bug has been logged online:

Bug reference:      2271
Logged by:          Peter laursen
Email address:      deepeter(at)snaps(dot)dk
PostgreSQL version: 8.1.3.1
Operating system:   Win XP SP2 Home - Dansih
Description:        no privilege to install
Details: 

I installed 8.1.1.1 successfully some months ago.  An update to 8.1.3.1
fails.  Server program installs (Files copy, registry values are written)
but service does not install due to privilege issue.

However my user account is an ADMINISTRATOR account.  But as ADMINISTRATOR
in WinXP HOME is another implementation than in WinXP PROFESSIONAL, I
suspect that the installer does not realize that difference!  And I had no
problems with 8.1.1.1 of the kind and also not MySQL, Apache and other
programs installing services.

With XP Home I have no option to grant more privileges, except than logging
on as user 'ADMINISTRATOR' from fail-safe mode.  However running
MSI-installer from failsafe mode is not possible/allowed. :-(

I 'worked around' the problem by running the UPGRADE.BAT until MSGBOX with
privilege issue occurred.  Instead of cancelling the install I then killed
MSI from Task Manager.  

The service that was there from the 8.1.1.1 install starts OK and PGADMIN
now identifies the server version  as 8.1.3.1 and everything seems to work
OK.

However this should not occur!

pgsql-bugs by date

Next:From: MonDate: 2006-02-18 13:54:24
Subject: BUG #2272: stop
Previous:From: EliasDate: 2006-02-17 20:29:11
Subject: BUG #2270: not accepted user and password

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group