Skip site navigation (1) Skip section navigation (2)

Re: LATIN1/9 conversion....

From: Ludek Finstrle <luf(at)pzkagis(dot)cz>
To: Tim Clarke <Tim(dot)Clarke(at)manifest(dot)co(dot)uk>
Cc: pgsql-odbc(at)postgresql(dot)org
Subject: Re: LATIN1/9 conversion....
Date: 2006-02-09 15:21:02
Message-ID: 20060209152101.GA1178@soptik.pzkagis.cz (view raw or flat)
Thread:
Lists: pgsql-odbc
Hello,

  I'm not much experienced in encoding.

> You can clearly see my latin1 request followed shortly by the latin9. I
> have examined the ODBC code and it looks like the culprit is a code page
> of 1252.

It could be interesting to see mylog output from Windows.
I don't understand well why it choose latin1 and then latin9.
Don't you specify 'set client_encoding to latin1' in DataSource
settings?
I'm new developer since 08.01 version so please be patient with me.

> Am I tracing this right? What do I do about? Suggestions, please!

You could use way of unicode driver. It use UTF-8 so no error occurs
with latin 1 x latin 9.
It means you may use "PostgreSQL Unicode" driver instead of
"PostgreSQL ANSI"

To other developers:
  Another one user points to problems with win1252 -> Latin 9 mapping.
It seems to me that Latin 9 isn't right default choise for win1252.
What do you mean?

Regards,

Luf

In response to

pgsql-odbc by date

Next:From: Ludek FinstrleDate: 2006-02-09 15:27:08
Subject: Re: COPY FROM
Previous:From: Shelby CainDate: 2006-02-09 15:04:07
Subject: Re: [ODBC] Problem using ODBC from .NET framework

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group