Skip site navigation (1) Skip section navigation (2)

Re: Upgrading from < 8.1 with users and groups with same name

From: Martin Pitt <martin(at)piware(dot)de>
To: PostgreSQL Bugs <pgsql-bugs(at)postgresql(dot)org>
Subject: Re: Upgrading from < 8.1 with users and groups with same name
Date: 2005-12-30 10:19:19
Message-ID: 20051230101919.GA14308@box79162.elkhouse.de (view raw or flat)
Thread:
Lists: pgsql-bugs
Hi Bruce!

Bruce Momjian [2005-12-29 20:06 -0500]:
> I think we decided that the number of users who have this problem and 
> would be using upgraded pg_dumpall to upgrade to 8.1 is too small.  (If
> we had realized this problem pre-8.1, it would have been great to have
> fixed it.)  In your upgrade script, you _know_ they are going to use
> your code for the upgrade so it is much more useful for you to check it.

Fine for me; of course I cannot force Debian users to use
pg_upgradecluster (the script that contains all the hairy details and
checks), there are people who do it the manual way.

I just reported it here since other distributions have the same
problem, so knowing the official upstream approach is always helpful.
:)

Thank you,

Martin

-- 
Martin Pitt              http://www.piware.de
Ubuntu Developer   http://www.ubuntulinux.org
Debian Developer        http://www.debian.org

In response to

pgsql-bugs by date

Next:From: Martin PittDate: 2005-12-30 10:25:38
Subject: Re: Upgrading from < 8.1 with users and groups with same name
Previous:From: Robert OsowieckiDate: 2005-12-30 09:43:52
Subject: BUG #2136: plperl doesn't work, plperlu - yes

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group