Skip site navigation (1) Skip section navigation (2)

[ psqlodbc-Bugs-1000417 ] odbc_lib_connect() returns "Specified driver could not be loaded due to system error 182 (PostgreSQL ANSI)"

From: <noreply(at)pgfoundry(dot)org>
To: noreply(at)pgfoundry(dot)org
Subject: [ psqlodbc-Bugs-1000417 ] odbc_lib_connect() returns "Specified driver could not be loaded due to system error 182 (PostgreSQL ANSI)"
Date: 2005-11-24 14:25:40
Message-ID: 20051124142540.3356E112509A@pgfoundry.org (view raw or flat)
Thread:
Lists: pgsql-odbc
Bugs item #1000417, was opened at 2005-11-08 17:08
You can respond by visiting: 
http://pgfoundry.org/tracker/?func=detail&atid=538&aid=1000417&group_id=1000125

Category: None
Group: None
>Status: Closed
Resolution: None
Priority: 3
Submitted By: Nobody (None)
Assigned to: Nobody (None)
>Summary: odbc_lib_connect() returns "Specified driver could not be loaded due to system error  182 (PostgreSQL ANSI)"

Initial Comment:
Hi,

WinXP Pro 
PostgreSQL 8.1
psqlodbc 8.01.01 5/11/2005

This is fresh installation. Psql works fine. PgAdmin works fine. Just ODBC returns the error mentioned in the summary,

Jano1122(at)hotmail(dot)com

----------------------------------------------------------------------

>Comment By: Dave Page  (dpage)
Date: 2005-11-24 14:25

Message:
No response from original poster. Tracker closed.

----------------------------------------------------------------------

Comment By: Nobody (None)
Date: 2005-11-17 14:28

Message:
I had the same problem, due to a parallel installation of PgOleDb. When I removed PgOleDb, I was able to connect again.

Regards,
Christian

----------------------------------------------------------------------

Comment By: Dave Page  (dpage)
Date: 2005-11-14 08:30

Message:
Can you confirm that the following files can be found alongside psqlodbca.dll in the installation directory:

libpq.dll
krb5_32.dll
comerr32.dll
libintl-2.dll
libiconv-2.dll
libeay32.dll
ssleay32.dll

Also, please check the path to the driver is correct in the registry key: HKEY_LOCAL_MACHINE\Software\ODBC\odbcinst.ini\PostgreSQL ANSI\driver

----------------------------------------------------------------------

Comment By: Dave Page  (dpage)
Date: 2005-11-14 08:26

Message:
>From 1000418:

Hi,
t
he psqlodbc 07.03.0200 works just fine. I have it up and running :-) but 8.01.01 fails :-(

Regards,
Jano1122(at)hotmail(dot)com

----------------------------------------------------------------------

You can respond by visiting: 
http://pgfoundry.org/tracker/?func=detail&atid=538&aid=1000417&group_id=1000125

pgsql-odbc by date

Next:From: Dave PageDate: 2005-11-24 15:23:22
Subject: Re: Continuing encoding fun....
Previous:From: noreplyDate: 2005-11-24 14:24:34
Subject: [ psqlodbc-Bugs-1000414 ] file based dns does not connect

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group