Skip site navigation (1) Skip section navigation (2)

Re: Problem Connecting to DB After 8.1 Upgrade

From: <operationsengineer1(at)yahoo(dot)com>
To: "pgsql-novice(at)postgresql(dot)org" <pgsql-novice(at)postgresql(dot)org>
Subject: Re: Problem Connecting to DB After 8.1 Upgrade
Date: 2005-11-14 21:14:26
Message-ID: 20051114211426.92785.qmail@web33307.mail.mud.yahoo.com (view raw or flat)
Thread:
Lists: pgsql-novice
--- Jaime Casanova <systemguards(at)gmail(dot)com> wrote:

> On 11/14/05, operationsengineer1(at)yahoo(dot)com
> <operationsengineer1(at)yahoo(dot)com> wrote:
> > --- operationsengineer1(at)yahoo(dot)com wrote:
> >
> > > i have the following adodb code (which shouldn't
> be
> > > too hard to figure out for those not familiar
> with
> > > adodb):
> > >
> > > $db = &ADONewConnection('postgres8');
> > >
> >
>
$db->Connect('localhost','postgres','3mydata5','mydb');
> > > if (!$db) die('Connection failed');
> > > $db->debug = true;
> > >
> > > $sql_product = 'SELECT product_id,
> product_number
> > > FROM
> > > t_product ' .
> > > 'ORDER BY product_number ASC';
> > >
> > > $sql_employee = 'SELECT employee_id, first_name
> ||
> > > \'
> > > \' || last_name FROM t_employee ORDER BY
> > > LOWER(first_name) ASC';
> > >
> > > $db->StartTrans();
> > > $rs_product = $db->Execute($sql_product);
> > > $rs_employee = $db->Execute($sql_employee);
> > > $db->CompleteTrans();
> > >
> > > $db is true, but i don't think i'm connecting to
> the
> > > db.  i can echo text prior to the transaction,
> but i
> > > can't echo anything after the transaction.  i
> > > removed
> > > the transaction and just left the Execute
> statements
> > > -
> > > same problem.
> > >
> > > does anyone have any idea why this isn't
> working?
> > >
> > > tia...
> >
> > upon further review, it appears my users and
> groups
> > didn't survive the backup and restore procedure
> since
> > pgsql 8.1 is looking for group roles and login
> roles.
> >
> > even so, i don't understand why postgres (a
> current
> > login role) is not connecting to the db.
> >
> > i will try and mimic my prior setup and go from
> there.
> >
> >
> 
> provide some info from your postgres log files
> (error messages)...

if you could give me the name of the file, i'll search
for it and post the contents.

> have configurated the pg_hba.conf and
> postgresql.conf?

i don't recall having to do this for 7.4.x (i might
have done something TCP/IP related, but that was it,
IIRC).  did anything change going to 8.1?

> all your users and groups will turn into roles are
> you sure you can
> login from them?

this did not occur in my case - the users and groups
didn't transfer.  the only role i had in the new db is
postgres.

i've linked my pg_restore output here....

http://www.geocities.com/operationsengineer1/pgsql_restore.xhtml

i created the db then did a restore...  i'm not sure
if that is the correct procedure.

i tried creating a simple new database with no
password and i can't connect to it either.

> --
> Atentamente,
> Jaime Casanova
> (DBA: DataBase Aniquilator ;)

tia for the help...


		
__________________________________ 
Start your day with Yahoo! - Make it your home page! 
http://www.yahoo.com/r/hs

In response to

Responses

pgsql-novice by date

Next:From: operationsengineer1Date: 2005-11-15 00:46:54
Subject: Re: Problem Connecting to DB After 8.1 Upgrade
Previous:From: Jaime CasanovaDate: 2005-11-14 19:04:21
Subject: Re: Problem Connecting to DB After 8.1 Upgrade

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group