Skip site navigation (1) Skip section navigation (2)

BUG #1970: Existing /etc/pam.d/postgresql clobbered by RPM install

From: "Mark Gibson" <gibsonm(at)cromwell(dot)co(dot)uk>
To: pgsql-bugs(at)postgresql(dot)org
Subject: BUG #1970: Existing /etc/pam.d/postgresql clobbered by RPM install
Date: 2005-10-17 07:47:17
Message-ID: 20051017074717.338B4F0D79@svr2.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-bugs
The following bug has been logged online:

Bug reference:      1970
Logged by:          Mark Gibson
Email address:      gibsonm(at)cromwell(dot)co(dot)uk
PostgreSQL version: 8.0.4
Operating system:   Redhat Enterprise Linux 4
Description:        Existing /etc/pam.d/postgresql clobbered by RPM install
Details: 

Hello, I noticed that when installing the 8.0.4 RPM's
it replaced our existing /etc/pam.d/postgresql - this caused our system to
break temporarily, as it was missing the following line:

account  required  pam_stack.so service=system-auth

I don't know whether this is required for all systems or is just a
peculiarity of our setup, but could the RPM be changed to not clobber this
file in the future. I believe some RPM's install conflicting configs with
the .rpmnew extension. Cheers.

Responses

pgsql-bugs by date

Next:From: Yogaraj. CDate: 2005-10-17 11:50:29
Subject: BUG #1971: Start Transaction is giving Errors !!!
Previous:From: jayeshDate: 2005-10-17 04:52:02
Subject: BUG #1969: Unable to Install

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group