Skip site navigation (1) Skip section navigation (2)

Re: Patch to fix plpython on OS X

From: Michael Fuhr <mike(at)fuhr(dot)org>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: "Jim C(dot) Nasby" <decibel(at)decibel(dot)org>,pgsql-patches(at)postgresql(dot)org, pgsql-hackers(at)postgresql(dot)org
Subject: Re: Patch to fix plpython on OS X
Date: 2005-07-19 19:54:00
Message-ID: 20050719195400.GA27471@winnie.fuhr.org (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-patches
On Tue, Jul 19, 2005 at 02:48:52PM -0400, Tom Lane wrote:
> "Jim C. Nasby" <decibel(at)decibel(dot)org> writes:
> > I don't think it's a version issue; cuckoo is at 2.4, platypus used to
> > be at 2.3 but I upgraded it to 2.4 to see if that was the issue, but
> > platypus kept working.
> 
> Hmm ... if it's *not* a version thing then I really do want to know
> what's causing it.  Anyone have an idea why this machine is saying
> '\u80' where everyone else's python says u'\x80' ?

Is it possible that plpython.so is linked against an old version
of libpython?  I see that the error message changed a few years ago:

http://cvs.sourceforge.net/viewcvs.py/python/python/dist/src/Python/exceptions.c?r1=1.44&r2=1.45
http://cvs.sourceforge.net/viewcvs.py/python/python/dist/src/Python/exceptions.c?r1=1.45&r2=1.46

As I recall, Python must be configured with --enable-shared or you
don't get a shared version of libpython, so if you installed a new
Python but not a new version of libpython.*.so, then plpython.so
might be linked against an old version.

Does this machine have ldd or the equivalent?  If so, can you compare
"ldd /path/to/python" and "ldd /path/to/plpython.so"?

-- 
Michael Fuhr
http://www.fuhr.org/~mfuhr/

In response to

Responses

pgsql-hackers by date

Next:From: Jim C. NasbyDate: 2005-07-19 19:56:19
Subject: Re: More buildfarm stuff
Previous:From: Andrew DunstanDate: 2005-07-19 19:53:26
Subject: Re: More buildfarm stuff

pgsql-patches by date

Next:From: Mark WongDate: 2005-07-19 19:54:53
Subject: Re: COPY FROM performance improvements
Previous:From: Tom LaneDate: 2005-07-19 18:48:52
Subject: Re: Patch to fix plpython on OS X

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group