Skip site navigation (1) Skip section navigation (2)

pgsql: The issue has been raised in the past that our build system links

From: neilc(at)svr1(dot)postgresql(dot)org (Neil Conway)
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: The issue has been raised in the past that our build system links
Date: 2005-05-05 11:50:18
Message-ID: 20050505115018.A336C54071@svr1.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-committers
Log Message:
-----------
The issue has been raised in the past that our build system links each
executable against the maximal set of libraries it might need. So for
example, if one executable requires `libreadline', all executables are
linked against it.

The easiest fix is to make use of GNU ld's --as-needed flag, which
ignores linker arguments that are not actually needed by the specified
object files. The attached patch modifies configure to check for this
flag (when using GNU ld), and if ld supports it, adds the flag to
LDFLAGS (we need to do the check since only relatively recent versions
of GNU ld support this capability). Currently only GNU ld is supported;
I'm not aware of any other linkers that support this functionality.

Modified Files:
--------------
    pgsql:
        configure (r1.434 -> r1.435)
        (http://developer.postgresql.org/cvsweb.cgi/pgsql/configure.diff?r1=1.434&r2=1.435)
        configure.in (r1.407 -> r1.408)
        (http://developer.postgresql.org/cvsweb.cgi/pgsql/configure.in.diff?r1=1.407&r2=1.408)

pgsql-committers by date

Next:From: User MhaDate: 2005-05-05 14:48:44
Subject: pginstaller - web: Add note about silent install not checking DLL
Previous:From: Tom LaneDate: 2005-05-05 03:37:23
Subject: pgsql: Adjust nodeBitmapIndexscan to keep the target index opened from

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group