Skip site navigation (1) Skip section navigation (2)

Re: libpq API incompatibility between 7.4 and 8.0

From: Peter Eisentraut <peter_e(at)gmx(dot)net>
To: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
Cc: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>,Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Martin Pitt <mpitt(at)debian(dot)org>
Subject: Re: libpq API incompatibility between 7.4 and 8.0
Date: 2005-02-04 11:26:16
Message-ID: 200502041226.17812.peter_e@gmx.net (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-patches
Am Donnerstag, 3. Februar 2005 15:42 schrieb Bruce Momjian:
> Peter Eisentraut wrote:
> > Bruce Momjian wrote:
> > > Uh, if we bump up the major library version in 8.0.X, will that
> > > require 8.0.0 user applications to be recompiled?
> >
> > No, they just keep using the old library.
>
> That assumes the old libraries stay around.  Will they?

Well, if someone did remove them then they didn't understand the point of the 
whole thing and should not be allowed to install libraries without 
supervision. :)

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

In response to

Responses

pgsql-hackers by date

Next:From: Neil ConwayDate: 2005-02-04 12:12:54
Subject: Re: Connect By for 8.0
Previous:From: Bruce MomjianDate: 2005-02-04 05:02:18
Subject: Re: Escaping the ARC patent

pgsql-patches by date

Next:From: Bruce MomjianDate: 2005-02-04 14:33:11
Subject: Re: libpq API incompatibility between 7.4 and 8.0
Previous:From: Simon RiggsDate: 2005-02-04 04:57:11
Subject: Re: Proof-of-concept ARC removal patches

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group