Skip site navigation (1) Skip section navigation (2)

Re: libpq API incompatibility between 7.4 and 8.0

From: Peter Eisentraut <peter_e(at)gmx(dot)net>
To: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
Cc: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>,Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Martin Pitt <mpitt(at)debian(dot)org>
Subject: Re: libpq API incompatibility between 7.4 and 8.0
Date: 2005-02-03 06:59:19
Message-ID: 200502030759.20449.peter_e@gmx.net (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-patches
Bruce Momjian wrote:
> Uh, if we bump up the major library version in 8.0.X, will that
> require 8.0.0 user applications to be recompiled?

No, they just keep using the old library.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

In response to

Responses

pgsql-hackers by date

Next:From: Christopher Kings-LynneDate: 2005-02-03 09:27:41
Subject: Re: pg_dump bug in 7.3.9 with sequences
Previous:From: Joshua D. DrakeDate: 2005-02-03 06:56:40
Subject: Re: pg_dump bug in 7.3.9 with sequences

pgsql-patches by date

Next:From: ITAGAKI TakahiroDate: 2005-02-03 10:25:55
Subject: Re: [PATCHES] WAL: O_DIRECT and multipage-writer (+ memory leak)
Previous:From: Greg StarkDate: 2005-02-03 03:43:42
Subject: Re: libpq API incompatibility between 7.4 and 8.0

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group