Skip site navigation (1) Skip section navigation (2)

Re: Problem with pl/perl in postgresql 8.0rc1

From: Michael Fuhr <mike(at)fuhr(dot)org>
To: Robert Boone <robert(at)rlb3(dot)com>
Cc: Kretschmer Andreas <andreas_kretschmer(at)despammed(dot)com>,PostgreSQL Novice <pgsql-novice(at)postgresql(dot)org>
Subject: Re: Problem with pl/perl in postgresql 8.0rc1
Date: 2004-12-17 17:13:47
Message-ID: 20041217171347.GA36449@winnie.fuhr.org (view raw or flat)
Thread:
Lists: pgsql-generalpgsql-novice
On Fri, Dec 17, 2004 at 10:04:29AM -0600, Robert Boone wrote:

> 	"/usr/lib/pgsql/plperl.so" is the only plperl.so I have. To check I
> did:
> 	find / -name plperl.so
> And the only result was:
> 	/usr/lib/pgsql/plperl.so

The error message is complaining about libperl.so, not plperl.so.
If you run "ldd /usr/lib/pgsql/plperl.so", one of the lines will
probably look like this:

  libperl.so => not found

Run "locate libperl.so" or "find / -name libperl.so" and see if you
have that file, which should be part of your Perl installation.  If
not, then maybe your Perl was built without shared library support.

-- 
Michael Fuhr
http://www.fuhr.org/~mfuhr/

In response to

pgsql-novice by date

Next:From: Tom LaneDate: 2004-12-17 17:22:52
Subject: Re: Problem with pl/perl in postgresql 8.0rc1
Previous:From: Robert BooneDate: 2004-12-17 16:52:07
Subject: Problem with pl/perl in postgresql 8.0rc1

pgsql-general by date

Next:From: Tom LaneDate: 2004-12-17 17:14:25
Subject: Re: sorting problem
Previous:From: Greg StarkDate: 2004-12-17 17:11:10
Subject: Re: sorting problem

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group