Skip site navigation (1) Skip section navigation (2)

sql problem with php

From: Flavio Fonseca <ff(at)dr(dot)ufu(dot)br>
To: pgsql-php(at)postgresql(dot)org
Subject: sql problem with php
Date: 2004-11-05 14:33:09
Message-ID: 200411051233.10080.ff@dr.ufu.br (view raw or flat)
Thread:
Lists: pgsql-php
Hi,

  I am having a problem with a system I developed using php with postgres.

Take a look at this:
Welcome to psql 7.3.2, the PostgreSQL interactive terminal.
NetAdmin=# delete from operador where oplogin = 'ff';
ERROR:  fk_historicosessao_operador referential integrity violation - key in 
operador still referenced from historicosessao

and then, this:

Welcome to psql 7.4.2, the PostgreSQL interactive terminal.
NetAdmin=# delete from operador where oplogin = 'ff';
ERROR:  update or delete on "operador" violates foreign key constraint 
"fk_historicosessao_operador" on "historicosessao"

I am not able to get a error_number in pgsql errors, only the error message. 
So when I used pgsql 7.3 a used the string "referential integrity violation" 
to detect this error, but on version 7.4 of pgsql this string was replaced 
with "violates foreign key constraint" . 
Anyone has a definitive solution on this or the way is to wait and change all 
my code on future releases of pgsql?


Thank you all for the attention.
-- 
Att.

Flavio Fonseca
Administrador de Redes
Divisao de Redes
Universidade Federal de Uberlandia

Responses

pgsql-php by date

Next:From: ljbDate: 2004-11-06 01:40:34
Subject: Re: sql problem with php
Previous:From: Jules AlbertsDate: 2004-10-27 20:28:05
Subject: Re: Fw: working with blobs in a two-server setup

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group