Skip site navigation (1) Skip section navigation (2)

Re: 7.4.5 stopped working?

From: "Mike G(dot)" <mike(at)thegodshalls(dot)com>
To: Klint Gore <kg(at)kgb(dot)une(dot)edu(dot)au>
Cc: pgsql-cygwin(at)postgresql(dot)org
Subject: Re: 7.4.5 stopped working?
Date: 2004-09-21 04:40:54
Message-ID: 20040921044054.GB22835@localhost.localdomain (view raw or flat)
Thread:
Lists: pgsql-cygwin
 Have you tried rebooting?  That error message usually happens when cygwin requests resouces from windows and fails.
 
 If you upgraded from a version prior to 7.4.2 then it is looking for the cygserver service to be running and in your path.
 
 Mike
> 
> On Tue, Sep 21, 2004 at 10:38:43AM +1000, Klint Gore wrote:
> > I had the latest cygwin postgres (as of yesterday) working when I went
> > home last night and this morning I cant start the postmaster.  I cant
> > think of anything that changed.
> > 
> > $ uname -a
> > CYGWIN_NT-5.0 kgb 1.5.11(0.116/4/2) 2004-09-04 23:17 i686 unknown unknown Cygwin
> > 
> > $ postmaster --version
> > postmaster (PostgreSQL) 7.4.5
> > 
> > cygserver starts and stays running.  last night it was a process and
> > thats how I started it this morning.  in trying to work out what's
> > happening, i've installed the service now.
> > 
> > $ /usr/sbin/cygserver --version
> > cygserver: (cygwin) 1.10
> > API version 1.5.11(0.116/4/1)-(3.0.0.2) 2004-09-04 23:17
> > Copyright 2001, 2002, 2003 Red Hat, Inc.
> > Compiled on Sep  4 2004
> > 
> > when I try to start the postmaster using
> >    pg_ctl -D /usr/local/pgsql/data -l /var/log/pgsql/logfile start
> > it just exits straight away.  
> > 
> > with normal logging the log file is empty.  with debug5 i get the envion
> > dump followed by
> > DEBUG:  -----------------------------------------
> > DEBUG:  found "/usr/bin/postgres" using argv[0]
> > DEBUG:  invoking IpcMemoryCreate(size=17776640)
> > 
> > config file is default except for (log settings added today after trying
> > to start failed; this install is just a tempory test so fsync=false is
> > acceptable)
> >   tcpip_socket=true
> >   shared_buffers=2000
> >   fsync=false
> >   log_min_messages=debug5
> >   log_min_error_statement=debug5
> > 
> > initdb was run yesterday with --locale=C
> > 
> > if I run "postmaster -D /usr/local/pgsql/data" i get the same invoking
> > ipcmemorycreate followed by "Bad system call"
> > 
> > Any ideas?
> > 
> > klint.
> > 
> > +---------------------------------------+-----------------+
> > : Klint Gore                            : "Non rhyming    :
> > : EMail   : kg(at)kgb(dot)une(dot)edu(dot)au           :  slang - the    :
> > : Snail   : A.B.R.I.                    :  possibilities  :
> > : Mail      University of New England   :  are useless"   :
> > :           Armidale NSW 2351 Australia :     L.J.J.      :
> > : Fax     : +61 2 6772 5376             :                 :
> > +---------------------------------------+-----------------+
> > 
> > ---------------------------(end of broadcast)---------------------------
> > TIP 9: the planner will ignore your desire to choose an index scan if your
> >       joining column's datatypes do not match

In response to

pgsql-cygwin by date

Next:From: Reini UrbanDate: 2004-09-21 10:24:01
Subject: Re: 7.4.5 stopped working?
Previous:From: Mike G.Date: 2004-09-21 04:39:59
Subject: Re: Cygwin on Win98: initdb failed

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group