Skip site navigation (1) Skip section navigation (2)

Fwd: Bug#260350: postgresql-dev: libpq3-config output is woeful

From: Martin Pitt <martin(at)piware(dot)de>
To: PostgreSQL Bugs <pgsql-bugs(at)postgresql(dot)org>
Subject: Fwd: Bug#260350: postgresql-dev: libpq3-config output is woeful
Date: 2004-08-30 11:26:08
Message-ID: 20040830112608.GA28692@box79162.elkhouse.de (view raw or flat)
Thread:
Lists: pgsql-bugs
Hi PostgreSQL developers!

Some time ago we got the following bug report. Since libpq3-config is
a simple shell script that echo's the required libraries, invoking it
with --cflags does not make much sense. However, -lpq should be added
and the relative library path should be replaced by an absolute
_destination_ path (of the system installation, not in the build
tree).

Thanks a lot in advance and have a nice day!

Martin
----- Forwarded message from Matthew Hawkins <matthew(at)intology(dot)com(dot)au> -----

Subject: Bug#260350: postgresql-dev: libpq3-config output is woeful
Reply-To: Matthew Hawkins <matthew(at)intology(dot)com(dot)au>, 260350(at)bugs(dot)debian(dot)org
From: Matthew Hawkins <matthew(at)intology(dot)com(dot)au>
To: Debian Bug Tracking System <submit(at)bugs(dot)debian(dot)org>
Date: Tue, 20 Jul 2004 15:00:14 +1000
X-Spam-Status: No, hits=-4.9 required=4.0 tests=BAYES_00 autolearn=ham 
	version=2.63

Package: postgresql-dev
Version: 7.4.3-3
Severity: normal

libpq3-config --libs gives:

-L../../../src/port -lssl -lcrypto -lkrb5 -lcrypt -lresolv -lnsl -lpthread

libpq3-config --cflags gives:

-L../../../src/port -lssl -lcrypto -lkrb5 -lcrypt -lresolv -lnsl -lpthread

Note both contain a relative path, the cflags output gives the same as
the libs output, and neither contains -lpq meaning applications will
still fail to link anyway.

Also, static linking appears to not work (unresolved symbols in the
kerberos stuff, even though the app I'm compiling doesn't even need
kerberos - is this related to bug 178214 ?)

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (990, 'unstable'), (800, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.7-ck5
Locale: LANG=en_AU, LC_CTYPE=en_AU

Versions of packages postgresql-dev depends on:
ii  libpq3                        7.4.3-3    Shared library libpq.so.3 for Post
ii  libssl-dev                    0.9.7d-4   SSL development libraries, header 

-- no debconf information



----- End forwarded message -----

-- 
Martin Pitt                 Debian GNU/Linux Developer
martin(at)piware(dot)de                      mpitt(at)debian(dot)org
http://www.piware.de             http://www.debian.org

Responses

pgsql-bugs by date

Next:From: Peter EisentrautDate: 2004-08-30 12:39:24
Subject: Re: Fwd: Bug#260350: postgresql-dev: libpq3-config output is woeful
Previous:From: Programação - CTINFDate: 2004-08-30 11:05:11
Subject: ODBC for v7.4.2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group