Skip site navigation (1) Skip section navigation (2)

Re: Python and 8.0 beta

From: Michael Fuhr <mike(at)fuhr(dot)org>
To: Tim Penhey <tim(at)penhey(dot)net>
Cc: pgsql-general <pgsql-general(at)postgresql(dot)org>
Subject: Re: Python and 8.0 beta
Date: 2004-08-24 04:07:35
Message-ID: 20040824040735.GA52054@winnie.fuhr.org (view raw or flat)
Thread:
Lists: pgsql-general
On Tue, Aug 24, 2004 at 12:12:35AM +0100, Tim Penhey wrote:
> Peter Eisentraut wrote:
> 
> >Tim Penhey wrote:
> >
> >>Are there any python drivers that work with the version 8 beta?
> >>The version seven ones didn't.
> >
> >Why?
> >
> Changed from using pyPgSQL to psycopg and things are working again...

Switching modules may fix your code but it doesn't fix the problem
with pyPgSQL.  I'm guessing that your code was failing with an
exception like the following:

libpq.DatabaseError: Ivalid [sic] format for PgVersion construction.

pyPgSQL's version string parsing fails at the "beta" portion
of "8.0.0beta1".  This has already been reported at Sourceforge
as Bug 1006782; I just followed up to that bug report with a
suggested fix.

-- 
Michael Fuhr
http://www.fuhr.org/~mfuhr/

In response to

pgsql-general by date

Next:From: Pablo SDate: 2004-08-24 04:13:34
Subject: Possible to insert quoted null value into integer field?
Previous:From: Tom LaneDate: 2004-08-24 04:02:49
Subject: Re: Unsupported 3rd-party solutions (Was: Few questions

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group