Skip site navigation (1) Skip section navigation (2)

Re: Compiling pgadmin on SuSE 9.1

From: Michael(dot)Eschweiler(at)t-online(dot)de (Michael Eschweiler)
To: pgadmin-support(at)postgresql(dot)org
Subject: Re: Compiling pgadmin on SuSE 9.1
Date: 2004-08-04 19:52:34
Message-ID: 200408042152.34803.michael.eschweiler@t-online.de (view raw or flat)
Thread:
Lists: pgadmin-hackerspgadmin-support
Hi Adam

Am Mittwoch, 4. August 2004 14:39 schrieben Sie:
> On Aug 2, 2004, at 4:27 PM, Michael Eschweiler wrote:
> > Am Montag, 2. August 2004 14:17 schrieben Sie:
> >> On Aug 1, 2004, at 7:26 AM, Michael Eschweiler wrote:
> >>> Hello,
> >>>
> >>> I'm trying to compile pgadmin3-1.0.2 on SuSE 9.1. When I run
> >>> ./configure I got
> >>> the error message: "configure: error: you must specify a valid pgsql
> >>> installation with --with-pgsql=DIR". Then I tried to do ./configure
> >>> with
> >>> several directories but I always got the same error-messages. Is
> >>> there
> >>> somebody who knows which exactly is the pgsql-directory on SuSE 9.1
> >>> and how
> >>> is the correct syntax to hand over it to configure?
>
> It looks like you have some sort of permissions problem:
>
> configure:4655: result: no
> configure:4673: checking libpq-fe.h usability
> configure:4686: gcc -c -g -O2  -DSSL -I/var/lib/pgsql//include
> conftest.c >&5
> cc1: /var/lib/pgsql/include: Permission denied
>
> configure:4705: result: no
> configure:4709: checking libpq-fe.h presence
> configure:4720: gcc -E  -DSSL -I/var/lib/pgsql//include conftest.c
> cc1: /var/lib/pgsql/include: Permission denied

> Whatever user you are running configure as doesn't have read
> permissions into /var/lib/pgsql/include

With this hints I controlled the permissions and it seems that this is not the 
problem. All files are readable for ugo. Nevertheless I tried to configure as 
root but I got the same result. 
I then tried to configure doing
./configure --with-pgsql-include=/usr/include/pgsql  
--with-pgsql=/var/lib/pgsql (and others --with-pgsql= which as I supposed 
could serve, using always --with-pgsql-include=/usr/include/pgsql)
but I am always left with 'configure: error: you must specify a valid pgsql 
installation with --with-pgsql=DIR'
As I don't know what configure is looking for when it's 'checking for PQexec' 
and I read on the screen (above the last error-message): 'PQexec in -lpq ... 
no'
I tried to read the configure-file and the config.log-file but I must confess 
I could not find the answer. Attached once more the config.log.
Thanks in advance
Michael 
>
> ahp


In response to

Responses

pgadmin-hackers by date

Next:From: Raphaël EnriciDate: 2004-08-04 21:21:37
Subject: Dynamic list of mirrors
Previous:From: cvsDate: 2004-08-04 19:23:34
Subject: CVS Commit by andreas: win32 fix for access of postmaster variables

pgadmin-support by date

Next:From: Adam H.PendletonDate: 2004-08-04 23:39:04
Subject: Re: Compiling pgadmin on SuSE 9.1
Previous:From: Michael EschweilerDate: 2004-08-02 20:27:15
Subject: Re: Compiling pgadmin on SuSE 9.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group