Skip site navigation (1) Skip section navigation (2)

Re: Unknown connect option (Get), Postgres 7.4.2

From: Adrian Klaver <aklaver(at)comcast(dot)net>
To: "'pgsql-odbc(at)postgresql(dot)org'" <pgsql-odbc(at)postgresql(dot)org>
Subject: Re: Unknown connect option (Get), Postgres 7.4.2
Date: 2004-05-23 17:15:09
Message-ID: 200405231015.09716.aklaver@comcast.net (view raw or flat)
Thread:
Lists: pgsql-odbc
PgAdminIII uses it own driver to connect unlike PgAdminII which uses ODBC.
I would agree with Jeff that the problem is with the Postgres setup not ODBC 
per se. Specifically, look at the pg_hba.conf file. This is where access is 
granted to the database. My guess is the new version has a different/more 
restrictive setup than the previous version.
On Sunday 23 May 2004 08:52 am, Jeff Eckermann wrote:
> My experience is that ODBC driver error messages are
> not always very helpful, when it comes to figuring out
> the cause of the failure.
>
> I think it most likely that the problem is not with
> ODBC or your application, but in the setup of the new
> PostgreSQL version.  Something in the connection or
> authentication parameters has changed.
>
> Being able to connect with PgAdminIII, but not with
> PgAdminII or MS Access, suggests to me that there is
> something different about the parameters being used by
> your setup for PgAdminIII.
>
> Make sure that the host name, database name, user name
> and password parameters that you are using really do
> have the values that you believe them to have, i.e.
> check everything.  If you find no error there, try
> connecting to the database with psql, using the same
> user name and password as in your app.
>
> If you still have a problem, post your results back to
> the list.
>
> --- Albin Blaschka <Albin(dot)Blaschka(at)bal(dot)bmlfuw(dot)gv(dot)at>
>
> wrote:
> > Hello,
> >
> > Following situation:
> >
> > I have updated to Postgres 7.4.2 from 7.3.2, the
> > ODBC-Driver stayed the same
> > We use Access (Office XP) with Windows 2000 as
> > frontend to our data
> >
> > But now after migration to the new database and a
> > new server, I get
> > following
> > error-messages when I want to connect via ODBC
> > (Access) or even via PGAdmin
> > II (but
> > PGAdmin III works...):
> >
> > (taken from the ODBC-Log)
> > CONN ERROR: func=PGAPI_GetConnectOption,
> > desc='fOption=30002', errnum=205,
> > errmsg='Unknown connect option (Get)'
> >
> > and a littler after that:
> >
> > CONN ERROR: func=PGAPI_DriverConnect, desc='Error
> > from CC_Connect',
> > errnum=105,
> > errmsg='The database does not exist on the server or
> > user authentication
> > failed.
> >
> > This last message appears then in Access (with
> > Errorcode #105) or in PGAdmin
> > II.
> >
> >
> > As said above, the connection from the same machine
> > to the database in
> > question
> > with PGAdmin III *works with no problems*...only
> > Access and PGAdmin II are
> > having
> > problems...
> >
> > The Database-Server now is a Debian "Sarge"
> > (testing) - Box
> > (the old one is a Debian "Woody")
> > Clients are Windows 2000, Access is from Office XP
> > ODBC-Driver Version is 7.03.02.00
> >
> > In the archives, I have found quite similar
> > questions/problems, but no
> > answers...
> > Some of the messages are quite outdated, maybe now
> > somebody araound here
> > knows
> > a solution or what I might have done wrong...
> >
> > Please help & thanks in advance!
> > Albin Blaschka
> >
> >
> > Here is the output of the psqlodbc-log:
> > CONN ERROR: func=PGAPI_GetConnectOption,
> > desc='fOption=30002', errnum=205,
> > errmsg='Unknown connect option (Get)'
>
> ------------------------------------------------------------
>
> >             henv=136060816, conn=136066856,
> > status=0, num_stmts=16
> >             sock=136060872, stmts=136060944,
> > lobj_type=-999
> >             ---------------- Socket Info
> > -------------------------------
> >             socket=-1, reverse=0, errornumber=0,
> > errormsg='(NULL)'
> >             buffer_in=136077856,
> > buffer_out=136081960
> >             buffer_filled_in=0, buffer_filled_out=0,
> > buffer_read_in=0
> > conn=136066856, PGAPI_DriverConnect(
> > in)='DSN=testing7.4.2;',
> > fDriverCompletion=1
> > DSN info:
>
> DSN='testing7.4.2',server='balappserver',port='5432',dbase='zuecht',user='a
>l
>
> > bin',passwd='xxxxx'
>
> onlyread='0',protocol='6.4',showoid='0',fakeoidindex='0',showsystable='0'
>
> >           conn_settings='',conn_encoding='OTHER'
> >           translation_dll='',translation_option=''
> > Global Options: Version='07.03.0200', fetch=100,
> > socket=4096,
> > unknown_sizes=0,
> >                 max_varchar_size=254,
> > max_longvarchar_size=8190
> >                 disable_optimizer=1, ksqo=1,
> > unique_index=1,
> > use_declarefetch=0
> >                 text_as_longvarchar=1,
> > unknowns_as_longvarchar=0,
> > bools_as_char=1 NAMEDATALEN=64
> >                 extra_systable_prefixes='pg_;',
> > conn_settings=''
> > conn_encoding='OTHER'
> >                 conn=136066856, query=' '
> > NOTICE from backend during send_query: 'LOG:
> > Anweisung:
> > '
> > NOTICE from backend during send_query: 'LOG:  Dauer:
> > 0.246 ms
> > '
> > CONN ERROR: func=PGAPI_DriverConnect, desc='Error
> > from CC_Connect',
> > errnum=105, errmsg='The database does not exist on
> > the server
> > or user authentication failed.'
>
> ------------------------------------------------------------
>
> >             henv=136060816, conn=136066856,
> > status=0, num_stmts=16
> >             sock=136060872, stmts=136060944,
> > lobj_type=-999
> >             ---------------- Socket Info
> > -------------------------------
> >             socket=964, reverse=0, errornumber=0,
> > errormsg='(NULL)'
> >             buffer_in=136077856,
> > buffer_out=136081960
> >             buffer_filled_in=48,
> > buffer_filled_out=0, buffer_read_in=48
> >
> > And here from the mylog-file:
> >
> > [1244]globals.extra_systable_prefixes = 'dd_;'
> > [1244][[SQLAllocHandle]][1244]**** in PGAPI_AllocEnv
> > **
> > [1244]** exit PGAPI_AllocEnv: phenv = 136060816 **
> > [1244][[SQLSetEnvAttr]] att=200,2
> > [1244][[SQLAllocHandle]][1244]PGAPI_AllocConnect:
> > entering...
> > [1244]**** PGAPI_AllocConnect: henv = 136060816,
> > conn = 136066856
> > [1244]EN_add_connection: self = 136060816, conn =
> > 136066856
> > [1244]       added at i =0, conn->henv = 136060816,
> > conns[i]->henv =
> > 136060816
> > [1244][SQLGetInfo(30)][1244]PGAPI_GetInfo:
> > entering...fInfoType=77
> > [1244]PGAPI_GetInfo: p='03.00', len=0, value=0,
> > cbMax=12
> > [1244][[SQLSetConnectAttr]] 103
> > [1244]PGAPI_SetConnectAttr 103
> > [1244]PGAPI_SetConnectOption: entering fOption = 103
> > vParam = 20
> > [1244][[SQLGetConnectAttr]] 30002
> > [1244]PGAPI_GetConnectAttr 30002
> > [1244]PGAPI_GetConnectOption: entering...
> > [1244]CONN ERROR: func=PGAPI_GetConnectOption,
> > desc='fOption=30002',
> > errnum=205, errmsg='Unknown connect option (Get)'
> > [1244][[SQLSetConnectAttr]] 30002
> > [1244]PGAPI_SetConnectAttr 30002
> > [1244]PGAPI_SetConnectOption: entering fOption =
> > 30002 vParam = 122428760
> > [1244]Microsoft Jet !!!!
> > [1244][SQLDriverConnect][1244]PGAPI_DriverConnect:
> > entering...
> > [1244]**** PGAPI_DriverConnect: fDriverCompletion=1,
> > connStrIn='DSN=testing7.4.2;'
> > [1244]our_connect_string = 'DSN=testing7.4.2;'
> > [1244]attribute = 'DSN', value = 'testing7.4.2'
> > [1244]copyAttributes:
>
> DSN='testing7.4.2',server='',dbase='',user='',passwd='xxxxx',port='',onlyre
>a
>
> d='',protocol='',conn_settings='',disallow_premature=-1)
>
> > [1244]globals.extra_systable_prefixes = 'pg_;'
> > [1244]our_connect_string = 'DSN=testing7.4.2;'
> > [1244]attribute = 'DSN', value = 'testing7.4.2'
> > [1244]CopyCommonAttributes:
>
> A7=100;A8=4096;A9=0;B0=254;B1=8190;B2=1;B3=1;B4=1;B5=1;B6=0;B7=1;B8=0;B9=1;
>C
>
> > 0=1;C1=0;C2=pg_;[1244]CC_connect: entering...
> > [1244]CC_connect(): DSN = 'testing7.4.2', server =
> > 'balappserver', port =
> > '5432', database = 'zuecht', username = 'albin',
> > password='xxxxx'
> > [1244]connecting to the server socket...
> > [1244]connection to the server socket succeeded.
> > [1244]sizeof startup packet = 292
> > [1244]sent the authentication block.
> > [1244]sent the authentication block successfully.
> > [1244]gonna do authentication
> > [1244]read 9, global_socket_buffersize=4096
> > [1244]auth got 'R'
> > [1244]areq = 5
> > [1244]in AUTH_REQ_MD5
> > [1244]read 15, global_socket_buffersize=4096
> > [1244]auth got 'R'
> > [1244]areq = 0
> > [1244]auth got 'K'
> > [1244]auth got 'Z'
>
> === message truncated ===
>
>
>
>
>
> __________________________________
> Do you Yahoo!?
> Yahoo! Domains – Claim yours for only $14.70/year
> http://smallbusiness.promotions.yahoo.com/offer
>
> ---------------------------(end of broadcast)---------------------------
> TIP 2: you can get off all lists at once with the unregister command
>     (send "unregister YourEmailAddressHere" to majordomo(at)postgresql(dot)org)

-- 
Adrian Klaver	
aklaver(at)comcast(dot)net

In response to

pgsql-odbc by date

Next:From: Philippe LangDate: 2004-05-24 09:32:39
Subject: user "Admin" does not exist / relation "mysysconf" does not exist
Previous:From: Jeff EckermannDate: 2004-05-23 15:52:53
Subject: Re: Unknown connect option (Get), Postgres 7.4.2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group