Skip site navigation (1) Skip section navigation (2)

Problems compiling for pgsql support

From: "Aaron" <aaron(at)vafishfreek(dot)com>
To: <pgsql-php(at)postgresql(dot)org>
Subject: Problems compiling for pgsql support
Date: 2004-03-19 02:42:05
Message-ID: 20040319024251.3E662444291@Server.vafishfreek.com (view raw or flat)
Thread:
Lists: pgsql-php
I have been trying to get php version 4.3.3 to work with postgresql for days
now.  I have postgresql installed and running on the server.  We are using
the WHM/Cpanel management suite so we are using apache 1.3.29 aswell.

I have php currently configured as reported by phpinfo() 

'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml'
'--enable-bcmath' '--enable-calendar' '--enable-ftp' '--with-gd'
'--with-jpeg-dir=/usr/local' '--with-png-dir=/usr'
'--with-xpm-dir=/usr/X11R6' '--with-gettext' '--enable-magic-quotes'
'--with-mysql' '--with-pear' '--enable-sockets' '--enable-track-vars'
'--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf'
'--enable-versioning' '--with-zlib' 

When I try to reconfigure php with the '--with-pgsql-dir=/usr' flag php
appears to compile and configure properly yet the builddate in phpinfo();
never changes.

In looking thru the php.net website it seems like there have been a lot of
issues with getting pgsql and php working properly.  I have exhaused my
ideas on what could be the cause and hope maybe someone out there might have
a few tricks I can try.

Thanks in advance.

Aaron


Responses

pgsql-php by date

Next:From: Raul SecanDate: 2004-03-19 09:49:36
Subject: Re: running postgresql as a linux service
Previous:From: Jeff MacDonaldDate: 2004-03-18 17:52:18
Subject: Re: running postgresql as a linux service

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group