Skip site navigation (1) Skip section navigation (2)

Initdb failing when installing Postgre on Cygwin

From: "bsytko" <bsytko(at)yahoo(dot)com>
To: <pgsql-cygwin(at)postgresql(dot)org>
Subject: Initdb failing when installing Postgre on Cygwin
Date: 2004-01-18 01:59:35
Message-ID: 20040118015911.44B45D1DA7C@svr1.postgresql.org (view raw or flat)
Thread:
Lists: pgsql-cygwin
Hello,

I am following a guide here:

http://www.ejip.net/faq/postgresql_win_setup_faq.jsp

And when I run this command:

Initdb -W -D /usr/local/pgsql/data

It says creating directory's and stuff and then it gives this error and
quits:

Creating template1 database in /usr/local/pgsql/data/base/1/... FATAL: could
not
 create shared memory segment: Function not implemented
DETAIL: Failed system call was shmget(key=1, size=1081344, 03600).

Initdb: failed
Initdb: removing data directory "/usr/local/pgsql/data"

I am using Cygwin version 1.5.5-1. I downloaded Cygipc version 1.14 and
installed it according to that guide. I used the PostgreSQL that came with
the downloaded Cygwin. I am running XP Pro w/ SP1. Thanks.

-Ben Sytko



Responses

pgsql-cygwin by date

Next:From: Pham Luu HungDate: 2004-01-19 05:03:20
Subject: How to get result of a query from MS DOS batch script or delete file from plpgsq
Previous:From: Peter EisentrautDate: 2004-01-16 18:19:16
Subject: Re: Adding long text to a text field generates an error

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group