Skip site navigation (1) Skip section navigation (2)

Re: PDF 7.4?

From: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
To: "Marc G(dot) Fournier" <scrappy(at)postgresql(dot)org>
Cc: "Joshua D(dot) Drake" <jd(at)commandprompt(dot)com>,Postgresql Advocacy <pgsql-advocacy(at)postgresql(dot)org>
Subject: Re: PDF 7.4?
Date: 2003-12-22 23:11:12
Message-ID: 200312222311.hBMNBC924135@candle.pha.pa.us (view raw or flat)
Thread:
Lists: pgsql-advocacy
Marc G. Fournier wrote:
> > > I realize ... was more concerned with the slew of errors scrolling up the
> > > screen previous to the error :)
> >
> > True, though sometimes you get meaningless errors and then the proper
> > error appears.
> 
> since you don't seem to generate any of the errors, even after a few
> hours, and svr1.postgresql.org does within a few minutes, how abot trying
> to do a 'gmake postgres.pdf' there and see if the errors make sense to
> you?

This is an error I got:

	openjade:postgres.sgml:5:55:W: cannot generate system identifier
	for public text "-//OASIS//DTD DocBook V4.2//EN"

You don't have Docbook 4.2 installed or it isn't being found.  That is
attempting to build HEAD, not 7.4.X, which uses docbook 3.2, I think.
What I don't understand is why the official developer build can build
HTML.

I just checked out REL 7.4.X and got:
	
	$ gmake postgres.pdf
	LC_ALL=C /usr/bin/perl
	/usr/local/share/sgml/docbook/dsssl/modular/bin/collateindex.pl -f -g -o
	bookindex.sgml -N
	{ \
	  echo "<!entity version \"7.4.1\">"; \
	  echo "<!entity majorversion \"`expr 7.4.1 :
	'\([0-9][0-9]*\.[0-9][0-9]*\)'`\">"; \
	} >version.sgml
	/usr/bin/perl ./mk_feature_tables.pl YES
	../../../src/backend/catalog/sql_feature_packages.txt
	../../../src/backend/catalog/sql_features.txt > features-supported.sgml
	/usr/bin/perl ./mk_feature_tables.pl NO
	../../../src/backend/catalog/sql_feature_packages.txt
	../../../src/backend/catalog/sql_features.txt >
	features-unsupported.sgml
	openjade  -D . -c /usr/local/share/sgml/docbook/dsssl/modular/catalog -d
	stylesheet.dsl -t tex -V tex-backend -i output-print -V texpdf-output -o
	postgres.tex-pdf postgres.sgml

and I see the errors you see.  Those look like missing index entries
generated by LaTeX.  Usually you have to run latex 3 times to get all
the index entries fixed, but rerunning the gmake doesn't seem to help.

Basically, I think if you fixed the final error, the build would
complete and you could re-run the gmake a few times more to remove the
warnings.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  pgman(at)candle(dot)pha(dot)pa(dot)us               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

In response to

Responses

pgsql-advocacy by date

Next:From: Marc G. FournierDate: 2003-12-22 23:26:16
Subject: Re: PDF 7.4?
Previous:From: Bruce MomjianDate: 2003-12-22 22:57:16
Subject: Re: PDF 7.4?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group