Skip site navigation (1) Skip section navigation (2)

Re: plperl does not build on RH7.1

From: "Holzheu" <holzheu(at)bitoek(dot)uni-bayreuth(dot)de>
To: "ADMIN" <pgsql-admin(at)postgresql(dot)org>
Subject: Re: plperl does not build on RH7.1
Date: 2003-12-22 08:20:42
Message-ID: 200312220820.hBM8KgC14501@bitoek.uni-bayreuth.de (view raw or flat)
Thread:
Lists: pgsql-admin
--------- Original-Nachricht --------
Von: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
An: Stefan Holzheu <stefan(dot)holzheu(at)bitoek(dot)uni-bayreuth(dot)de>
Cc: ADMIN <pgsql-admin(at)postgresql(dot)org>
Betreff: Re: [ADMIN] plperl does not build on RH7.1
Datum: 22/12/03 00:34

Thanks, Tom. I will try after Christmas.


>
> You need this patch:
>
> 2003-11-24 08:16  petere
>
> 	* configure, configure.in, src/include/pg_config.h.in,
> 	src/interfaces/ecpg/ecpglib/connect.c,
> 	src/interfaces/ecpg/ecpglib/misc.c, src/port/thread.c,
> 	src/tools/thread/thread_test.c: Rename USE_THREADS to
> 	ENABLE_THREAD_SAFETY to avoid name clash with Perl.  Fixes
> 	compilation failure with --enable-thread-safety --with-perl and
> 	Perl 5.6.1.
>
> Or, don't do --enable-thread-safety.
>
> 			regards, tom lane
>
> ---------------------------(end of broadcast)---------------------------
> TIP 6: Have you searched our list archives?
>
>                http://archives.postgresql.org
>
>
>
>
>
>
>

________________________________________________
Message sent using UebiMiau 2.7.2


pgsql-admin by date

Next:From: Oli SennhauserDate: 2003-12-22 11:07:35
Subject: CREATE USER system privilege?
Previous:From: Tom LaneDate: 2003-12-21 22:56:06
Subject: Re: plperl does not build on RH7.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group