Skip site navigation (1) Skip section navigation (2)

Re: Update PG-7.3.2 and tru64 5.1a

From: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
To: yogesh(at)gsf(dot)de
Cc: pgsql-admin(at)postgresql(dot)org, pgsql-ports(at)postgresql(dot)org
Subject: Re: Update PG-7.3.2 and tru64 5.1a
Date: 2003-07-25 15:55:01
Message-ID: 200307251555.h6PFt1522515@candle.pha.pa.us (view raw or flat)
Thread:
Lists: pgsql-adminpgsql-ports
It is complaining about not having libtermcap or libterminfo, or
libcurses, or libtermlib --- not sure which one on your OS.

It actually looks like libreadline didn't have the proper libraries
specified, and that is why it is failing.  Does psql work on your
platform?

---------------------------------------------------------------------------

yogesh bhanu wrote:
> Hi ,
>        Thanks to all who responded .
> 
>          I manage to get postgres compiled and now I'm stuck again :(.
> I got it to compile with Compaq CC with -ieee flags enabled but
> when I do gmake check I'm getting an error something like this
> 
> 
> 
> /bin/sh ./pg_regress --temp-install --top-builddir=../../.. 
> --schedule=./parallel_schedule --multibyte=SQL_ASCII
> ============== removing existing temp installation    ==============
> ============== creating temporary installation        ==============
> ============== initializing database system           ==============
> ============== starting postmaster                    ==============
> running on port 65432 with pid 889885
> ============== creating database "regression"         ==============
> CREATE DATABASE
> ALTER DATABASE
> ============== dropping regression test user accounts ==============
> ============== installing PL/pgSQL                    ==============
> ERROR:  Load of file 
> /usr/test/data/src/databases/postgresql-7.3.3/src/test/regress/./tmp_check/install//usr/local/postgres-7.3.x/lib/plpgsql.so 
> failed: dlopen: libreadline.so.4: symbol "tputs" unresolved
> createlang: language installation failed
> pg_regress: createlang failed
> gmake[2]: *** [check] Error 2
> gmake[2]: Leaving directory 
> `/usr/test/data/src/databases/postgresql-7.3.3/src/test/regress'
> gmake[1]: *** [check] Error 2
> gmake[1]: Leaving directory 
> `/usr/test/data/src/databases/postgresql-7.3.3/src/test'
> gmake: *** [check] Error 2
> 
> Any Ideas as to how to fix it .
> 
> I have compiled libreadline-4.3  using Compaq "CC -ieee".
> 
> Thanks in advance
> yogesh
> 
> 
> 
> 
> Hi
>       I did'nt get any mail for this in pgsql-ports so mailing here.
> I get the same error on 7.3.2 and on 7.3.3 .
> 
>         Just tried to compile postgres 7.3.3 on Tru64 5.1 a pk 4
> with
> Compaq C V6.5-207 (dtk) on Compaq Tru64 UNIX V5.1A (Rev. 1885)
> Compiler Driver V6.5-207 (dtk) (dtk) cc Driver
> My configure option is ..
> ./configure --prefix=/usr/local/postgres-7.3
> --with-includes=/usr/local/include --enable-static --with-pgport=12001
> --with-maxbackends=128
> 
> I get the following error at NAN when I compile .
> gmake[4]: Entering directory
> `/usr/test/data/src/databases/postgresql-7.3.2/src/backend/utils/adt'
> cc -std -O4 -Olimit 2000 -I../../../../src/include -I/usr/local/include
>     -c -o float.o float.c
> cc: Error: float.c, line 202: In this statement, the libraries on this
> platform do not yet support compile-time evaluation of the constant
> expression "0.0/0.0". (constfoldns)
>                            val = NAN;
> ------------------------------^
> cc: Error: float.c, line 263: In this statement, the libraries on this
> platform do not yet support compile-time evaluation of the constant
> expression "0.0/0.0". (constfoldns)
>                            val = NAN;
> ------------------------------^
> gmake[4]: *** [float.o] Error 1
> gmake[4]: Leaving directory
> `/usr/test/data/src/databases/postgresql-7.3.2/src/backend/utils/adt'
> gmake[3]: *** [adt-recursive] Error 2
> gmake[3]: Leaving directory
> `/usr/test/data/src/databases/postgresql-7.3.2/src/backend/utils'
> gmake[2]: *** [utils-recursive] Error 2
> gmake[2]: Leaving directory
> `/usr/test/data/src/databases/postgresql-7.3.2/src/backend'
> gmake[1]: *** [all] Error 2
> gmake[1]: Leaving directory
> `/usr/test/data/src/databases/postgresql-7.3.2/src'
> gmake: *** [all] Error 2
> 
> 
> also  could anyone also point me what values have to be raised for the
> IPC ...
> ipc:
> msg_max = 8192
> msg_mnb = 16384
> msg_mni = 64
> msg_tql = 40
> shm_max = 4278190080
> shm_min = 1024
> shm_mni = 256
> shm_seg = 128
> sem_mni = 16
> sem_msl = 25
> sem_opm = 10
> sem_ume = 10
> sem_vmx = 32767
> sem_aem = 16384
> sem_broadcast_wakeup = 1
> max_kernel_ports = 314912
> ssm_threshold = 8388608
> ssm_enable_core_dump = 1
> shm_allocate_striped = 1
> shm_enable_core_dump = 1
> 
> I will summarise
> 
> Thanx in advance
> yogesh
> 
> 
> 
> 
> 
> 
> 
> ---------------------------(end of broadcast)---------------------------
> TIP 1: subscribe and unsubscribe commands go to majordomo(at)postgresql(dot)org
> 
> 
> 
> 
> ---------------------------(end of broadcast)---------------------------
> TIP 2: you can get off all lists at once with the unregister command
>     (send "unregister YourEmailAddressHere" to majordomo(at)postgresql(dot)org)
> 

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  pgman(at)candle(dot)pha(dot)pa(dot)us               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

In response to

pgsql-ports by date

Next:From: Lamar OwenDate: 2003-07-28 22:55:20
Subject: RPMs for 7.3.4, and a change.
Previous:From: yogesh bhanuDate: 2003-07-25 15:47:32
Subject: Update PG-7.3.2 and tru64 5.1a

pgsql-admin by date

Next:From: mallahDate: 2003-07-25 17:56:35
Subject: cannot dump 7.3.3 table using pg_dump of 7.4dev
Previous:From: yogesh bhanuDate: 2003-07-25 15:47:32
Subject: Update PG-7.3.2 and tru64 5.1a

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group