Skip site navigation (1) Skip section navigation (2)

installation error ?

From: "utomo restu" <utomo(at)linuxmail(dot)org>
To: pgsql-admin(at)postgresql(dot)org
Subject: installation error ?
Date: 2003-06-01 00:28:43
Message-ID: 20030601002843.4308.qmail@linuxmail.org (view raw or flat)
Thread:
Lists: pgsql-admin
Dear All

Now i use postgresql version 7.2.2, i want to upgrade to versions 7.3.3,
when i start installation processing, i found error like this :

[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-7.3.3-1PGDG.i386.rpm
Preparing...                ########################################### [100%]
   1:postgresql             ########################################### [100%]

[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-server-7.3.3-1PGDG.i386.rpm
Preparing...                ########################################### [100%]
   1:postgresql-server      ########################################### [100%]

[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-devel-7.3.3-1PGDG.i386.rpm
Preparing...                ########################################### [100%]
   1:postgresql-devel       ########################################### [100%]

[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-tcl-7.3.3-1PGDG.i386.rpm
Preparing...                ########################################### [100%]
   1:postgresql-tcl         ########################################### [100%]

[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-python-7.3.3-1PGDG.i386.rpm
Preparing...                ########################################### [100%]
   1:postgresql-python      ########################################### [100%]

[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-jdbc-7.3.3-1PGDG.i386.rpm
Preparing...                ########################################### [100%]
   1:postgresql-jdbc        ########################################### [100%]


[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-contrib-7.3.3-1PGDG.i386.rpm
error: Failed dependencies:
        perl(Pg) is needed by postgresql-contrib-7.3.3-1PGDG
    Suggested resolutions:
        postgresql-perl-7.2.2-1.i386.rpm

[root(at)ksl postgres7.3.3_red8]# rpm -ivh postgresql-pl-7.3.3-1PGDG.i386.rpm
error: Failed dependencies:
        libpthread.so.0(GLIBC_2.3.2) is needed by postgresql-pl-7.3.3-1PGDG

what can i do, where i can found that dependencies...
please help me ...

thank's a lot..

best regards

andhie

-- 
______________________________________________
http://www.linuxmail.org/
Now with e-mail forwarding for only US$5.95/yr

Powered by Outblaze

Responses

pgsql-admin by date

Next:From: Bob WheldonDate: 2003-06-01 10:50:15
Subject: unsubscribe
Previous:From: Hans SpaansDate: 2003-05-31 22:46:18
Subject: Re: Yet another postgres scaling question (use on AMD Opteron)

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group