Skip site navigation (1) Skip section navigation (2)

Re: [HACKERS] Request for supported platforms

From: Jason Tishler <jason(at)tishler(dot)net>
To: Dave Page <dpage(at)vale-housing(dot)co(dot)uk>
Cc: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>,PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>,Thomas Lockhart <lockhart(at)fourpalms(dot)org>,Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>,Pgsql-Cygwin <pgsql-cygwin(at)postgresql(dot)org>
Subject: Re: [HACKERS] Request for supported platforms
Date: 2002-10-29 14:47:35
Message-ID: 20021029144734.GB1812@tishler.net (view raw or flat)
Thread:
Lists: pgsql-cygwinpgsql-hackers
Dave,

On Mon, Oct 28, 2002 at 08:58:12PM -0000, Dave Page wrote:
> > -----Original Message-----
> > From: Jason Tishler [mailto:jason(at)tishler(dot)net] 
> > Sent: 28 October 2002 20:42
> > Subject: Re: [HACKERS] Request for supported platforms
> > 
> > On Mon, Oct 28, 2002 at 11:20:16AM -0500, Jason Tishler wrote:
> > > My WAG is that you will be able to upgrade your Cygwin
> > > installation before I fix the Cygwin build issues. :,)
> > 
> > I guess my WAG was wrong... :,)
> 
> I've been meaning to ask this for a while - what exactly is a WAG? :-)

Larry was kind enough to answer this one for me.  :,)

> > 1. Cygwin bison needs to be upgraded from 1.35 to 1.75 (i.e., 
> > 1.50+) to process src/interfaces/ecpg/preproc/preproc.y 
> > successfully.  I will post to the Cygwin mailing list asking 
> > the maintainer for this upgrade.
> 
> OK. This shouldn't stop a release though I assume, only a build from
> CVS.

Yes.  Nevertheless, I have posted my request:

    http://cygwin.com/ml/cygwin/2002-10/msg01740.html

> > 2. The following fseeko/ftello ifdef in src/include/pg_config.h.in:
> > 
> >     #ifndef HAVE_FSEEKO
> >     #define fseeko(a, b, c) fseek((a), (b), (c))
> >     #define ftello(a) ftell((a))
> >     #endif
> > 
> > conflicts with the following Cygwin /usr/include/stdio.h entries:
> > 
> >     int _EXFUN(fseeko, (FILE *, off_t, int));
> >     off_t   _EXFUN(ftello, ( FILE *));
> > 
> > Unfortunately, I'm not sure what is the best way to solve 
> > this one yet. Any suggestions would be appreciated.

I found a solution to the above which will hopefully find its way into
the next Cygwin release:

    http://cygwin.com/ml/cygwin-patches/2002-q4/msg00042.html
    
> Yes, I'm seeing errors with this on my updated Cygwin very early in
> the build. I did think it was my hacked about installation, but I
> guess not!

A quick and *dirty* fix for this problem is to temporarily delete the
above two entries from your stdio.h file.

Jason

In response to

Responses

pgsql-cygwin by date

Next:From: Jason TishlerDate: 2002-10-29 14:54:20
Subject: Re: [HACKERS] Request for supported platforms
Previous:From: S. L.Date: 2002-10-29 08:05:55
Subject: Re: installing postgresql on W2K; starting postmaster fails

pgsql-hackers by date

Next:From: David WalkerDate: 2002-10-29 14:47:45
Subject: Re: Turning the PLANNER off
Previous:From: Adam WitneyDate: 2002-10-29 13:55:41
Subject: Re: Request for supported platforms

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group