Skip site navigation (1) Skip section navigation (2)

Re: Upgrading from 7.2.1 to 7.2.3 on RH7.3

From: "Jules Alberts" <jules(dot)alberts(at)arbodienst-limburg(dot)nl>
To: "'pgsql-novice(at)postgresql(dot)org'" <pgsql-novice(at)postgresql(dot)org>
Subject: Re: Upgrading from 7.2.1 to 7.2.3 on RH7.3
Date: 2002-10-28 15:06:07
Message-ID: 200210281514.g9SFEUE2025928@artemis.cuci.nl (view raw or flat)
Thread:
Lists: pgsql-novice
On 28 Oct 2002 at 9:46, Kassel Ben CRBE wrote:
> Suffice to say I havent a clue on what I am doing.
> 
> I am trying to upgrade to 7.2.3 using downloaded RPM's. The installation for 7.2.1 went quite well, but I cannot upgrade. Here is what happens:
> 
> [root(at)DOC root]# rpm -U postgresql-libs-7.2.3-1PGDG.i386.rpm
> error: failed dependencies:
>         postgresql-libs = 7.2.1 is needed by postgresql-7.2.1-4
>         postgresql-libs = 7.2.1 is needed by postgresql-server-7.2.1-4
>         postgresql-libs = 7.2.1 is needed by postgresql-devel-7.2.1-4

Put all the new RPMs in one dir, go there and say
	rpm -Fvh *.rpm

man rpm will tell you what it does.

> Okay, so lets just try to remove the existing application:
> 
> [root(at)DOC root]# rpm -e postgresql-7.2.1-4.i386.rpm

You can't remove postgresql-7.2.1-4.i386.rpm because it's not 
installed. However postgresql-7.2.1-4 probably is. So this should work
	rpm -e postgresql-7.2.1-4

If you want to know what's installed, do something like
	rpm -qa | grep postgres

This will give you: postgresql-7.2.1-4 (and other stuff). The names 
that you find here are valid package names.

HTH.

In response to

pgsql-novice by date

Next:From: Josh BerkusDate: 2002-10-28 17:05:45
Subject: Re: Sequences Question
Previous:From: Kassel Ben CRBEDate: 2002-10-28 14:46:42
Subject: Upgrading from 7.2.1 to 7.2.3 on RH7.3

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group