Skip site navigation (1) Skip section navigation (2)

Re: Upgrade process (was Re: 7.2.3?)

From: Lamar Owen <lamar(dot)owen(at)wgcr(dot)org>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>,Alvaro Herrera <alvherre(at)atentus(dot)com>
Cc: Justin Clift <justin(at)postgresql(dot)org>,Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>,PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: Upgrade process (was Re: 7.2.3?)
Date: 2002-09-28 21:05:58
Message-ID: 200209281705.58316.lamar.owen@wgcr.org (view raw or flat)
Thread:
Lists: pgsql-hackers
On Saturday 28 September 2002 04:57 pm, Tom Lane wrote:
> 7.3 we've changed tuple headers for space-saving reasons, and fixed
> some problems with alignment in array data.

> Going forward I think we should try to maintain compatibility of on-disk
> user data and ensure that pg_upgrade works.

This is of course a two-edged sword.

1.)	Keeping pg_upgrade working, which depends upon pg_dump working;
2.)	Maintaining security fixes for 7.2 for a good period of time to come, 
since migration from 7.2 to >7.2 isn't easy.

If pg_upgrade is going to be the cookie, then let's all try to test the 
cookie.  I'll certainly try to do my part.
-- 
Lamar Owen
WGCR Internet Radio
1 Peter 4:11

In response to

Responses

pgsql-hackers by date

Next:From: Tom LaneDate: 2002-09-28 21:22:02
Subject: Re: Upgrade process (was Re: 7.2.3?)
Previous:From: Lamar OwenDate: 2002-09-28 21:00:31
Subject: Re: 7.2.3?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group