Neil Conway wrote:
> On Tue, Jul 23, 2002 at 05:52:39PM -0400, Bruce Momjian wrote:
> > I agree with Peter that it is better to rename it pg_lock*. The show
> > isn't needed and it makes it look more like our other system info
> > tables.
> Well, it's not a system info table -- it's a built-in function, and I'm
> not aware of any naming conventions for those. Personally, I find it a
> bit confusing to do:
> SELECT * FROM pg_tables;
> SELECT * FROM pg_class;
> /* ... */
> SELECT * FROM pg_locks();
> However, I'm not really worried about the name, so I've changed it
> to pg_locks() -- a revised patch is attached.
Oh, I see. Should we make it appear as a table rather than a function?
Does that make any sense?
Bruce Momjian | http://candle.pha.pa.us
pgman(at)candle(dot)pha(dot)pa(dot)us | (610) 853-3000
+ If your life is a hard drive, | 830 Blythe Avenue
+ Christ can be your backup. | Drexel Hill, Pennsylvania 19026
In response to
pgsql-patches by date
|Next:||From: Christopher Kings-Lynne||Date: 2002-07-24 01:45:06|
|Subject: Re: [PATCHES] Demo patch for DROP COLUMN|
|Previous:||From: Joe Conway||Date: 2002-07-23 23:23:30|
|Subject: Re: [PATCHES] prepareable statements|