Skip site navigation (1) Skip section navigation (2)

Re: [HACKERS] Problem on AIX with current

From: Tatsuo Ishii <t-ishii(at)sra(dot)co(dot)jp>
To: ZeugswetterA(at)spardat(dot)at
Cc: tgl(at)sss(dot)pgh(dot)pa(dot)us, pgsql-hackers(at)postgresql(dot)org, pgsql-patches(at)postgresql(dot)org
Subject: Re: [HACKERS] Problem on AIX with current
Date: 2001-10-05 01:45:49
Message-ID: 20011005104549Y.t-ishii@sra.co.jp (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-patches
> > > Only problem on AIX is, that the argv[0] stuff does not work anymore
> > > (I think since we don't exec() anymore), which is rather annoying.
> > 
> > Hmm, perhaps we are selecting the wrong PS_STRINGS method for AIX?
> > Please look at src/backend/utils/misc/ps_status.c and see if one of
> > the other methods will work on AIX.
> 
> Yes, I see. Quite silly that I did not look earlier. 
> The compiler does not define _AIX4 or _AIX3, no idea who thought that. 
> It only defines _AIX, _AIX32, _AIX41 and _AIX43. 
> 
> I am quite sure that all AIX Versions accept the CLOBBER method,
> thus I ask you to apply the following patch, to make it work.

CLOBBER does not work with AIX5L, nor CHANGE_ARGV. (SETPROCTITLE,
PSTAT and PS_STRINGS can not be used since AIX5L does not have
appropreate header files).
--
Tatsuo Ishii


In response to

pgsql-hackers by date

Next:From: John SummerfieldDate: 2001-10-05 02:03:14
Subject: Re: cvs problem
Previous:From: John SummerfieldDate: 2001-10-05 01:40:22
Subject: Re: cvs problem

pgsql-patches by date

Next:From: Bruce MomjianDate: 2001-10-05 02:38:40
Subject: Re: [HACKERS] Problem on AIX with current
Previous:From: Barry LindDate: 2001-10-05 01:19:02
Subject: Re: Patch for handling unknown data types in jdbc driver

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group