> Bruce Momjian - CVS <momjian(at)hub(dot)org> writes:
> > Rename ParseFuncOrColumn() to ParseColumnOrFunc().
> This is an improvement?
> Considering that the function is primarily concerned with parsing
> function calls, I'd call this a net decrease in intelligibility.
Here is my comment added to the top of the code. Is it correct?
* parse function
* This code is confusing code because the database can accept
* relation.column, column.function, or relation.column.function.
* It can also be called as func(col) or func(col,col).
* Funcname is the first parameter, and fargs are the rest.
ParseColumnOrFunc(ParseState *pstate, char *funcname, List *fargs,
bool agg_star, bool agg_distinct,
Bruce Momjian | http://candle.pha.pa.us
pgman(at)candle(dot)pha(dot)pa(dot)us | (610) 853-3000
+ If your life is a hard drive, | 830 Blythe Avenue
+ Christ can be your backup. | Drexel Hill, Pennsylvania 19026
In response to
pgsql-committers by date
|Next:||From: Tom Lane||Date: 2001-05-18 23:00:31|
|Subject: Re: pgsql/src backend/catalog/index.c backend/pars ... |
|Previous:||From: Bruce Momjian - CVS||Date: 2001-05-18 22:54:23|
|Subject: pgsql/src/backend parser/parse_func.c utils/ad ...|