Skip site navigation (1) Skip section navigation (2)

Re: odbc bug?

From: Lonnie Cumberland <lonnie_cumberland(at)yahoo(dot)com>
To: pgsql-bugs(at)postgresql(dot)org
Subject: Re: odbc bug?
Date: 2001-03-14 19:26:21
Message-ID: 20010314192621.47125.qmail@web12505.mail.yahoo.com (view raw or flat)
Thread:
Lists: pgsql-bugs
Hello,

Thanks for the quick response.

if I use the "odbctest" to see if my program is there then I get one thing and
if I use "odbctest DNS=PostgreSQL", I get something else

[root(at)Treazurac samples]# ./odbctest
OpenLink ODBC Demonstration program
This program shows an interactive SQL processor


Enter ODBC connect string (? shows list): DNS=PostgreSQL
[iODBC][Driver Manager]Dialog failed, SQLSTATE=IM008

Have a nice day.
[root(at)Treazurac samples]# ./odbctest DNS=PostgreSQL
OpenLink ODBC Demonstration program
This program shows an interactive SQL processor

[iODBC][Driver Manager]Dialog failed, SQLSTATE=IM008

Have a nice day.
---------------------------------------------------

My odbc.ini is:
-------------------------------------------------
;
; odbc.ini
;
[ODBC Data Sources]
OpenLink = OpenLink (MT)

[PostgreSQL]
Description = PostgreSQL driver for Linux
Driver = PostgreSQL
Trace = Yes
TraceFile = /tmp/sql.log
Host = localhost
ServerType = PostgreSQL
FetchBufferSize = 99
UserName =
Password =
Database =
ServerOptions =
ConnectOptions =
Options =
ReadOnly = no
Port = 5432
;Protocol = 6.4
;RowVersioning = No
;ShowSystemTables = No
;ShowOidColumn = No
;FakeOidIndex = No
;ConnSettings =

--------------------------------------------------
and my odbcinst.ini is
-----------------------------------------------
[PostgreSQL]
Description = PostgreSQL driver for Linux
Driver = /usr/lib/libodbcpsql.so
Setup = /usr/lib/libodbcpsqlS.so
FileUsage = 1

-------------------------------------------------

The MetaHTML is located on the same Linux machine as this odbc manager also.

I do not seem to have this ./oplrqb from ~/openlink/bin as I got these drivers
from

libiodbc-2.50-3.i386-glibc2.rpm
libiodbc-devel-2.50-3.i386-glibc2.rpm

And have installed the PostgreSQL 7.0.3 from the RPM's on their site along with
the PostgreSQL ODBC 7.0.3 drivers from their site as well.

I started the Broker in two ways with the same results:

I ran the standard /etc/init.d/postgresql start daemon and I also tried another
way when things did not communicate by:

su -l postgres -c "postmaster -i -d 2 -p 5432 -D /var/lib/pgsql/data "

Which also seemed not to communicate with the odbc manager as well. I checked
for communications by using the odbctest and MetaHTML applications along with
one other one which also gave me:

[root(at)Treazurac tests]# ./scroll PostgreSQL
Connecting to PostgreSQL...
Failed to connect to datasource: [iODBC][Driver Manager]Dialog failed

I am at a loss as to the problem and how to fix it.

Best Regards,
Lonnie


__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices.
http://auctions.yahoo.com/

pgsql-bugs by date

Next:From: Rickard AnnellDate: 2001-03-15 12:43:38
Subject: Swedish characters
Previous:From: Tom LaneDate: 2001-03-14 18:40:55
Subject: Re: odbc bug?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group