Skip site navigation (1) Skip section navigation (2)

Re: postgresql-7.1beta5 with Heimdal-0.3e

From: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
To: "Dmitry G (dot) Mastrukov" <dmitry(at)taurussoft(dot)org>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: postgresql-7.1beta5 with Heimdal-0.3e
Date: 2001-02-27 16:14:53
Message-ID: 200102271614.LAA14860@candle.pha.pa.us (view raw or flat)
Thread:
Lists: pgsql-bugs
Not sure how to handle this.  I have never heard of Heimdal, and I am
afraid these changes will adversely affect other Kerberos users.  My
inclination is to not make any changes and wait to see if another user
reports a problem.


[ Charset KOI8-R unsupported, converting... ]
> ============================================================================
>                         POSTGRESQL BUG REPORT TEMPLATE
> ============================================================================
> 
> 
> Your name		:	Dmitry G. Mastrukov
> Your email address	: dmitry(at)taurussoft(dot)org
> 
> 
> System Configuration
> ---------------------
>   Architecture (example: Intel Pentium)  	: Intel Pentium
> 
>   Operating System (example: Linux 2.0.26 ELF) 	: Linux 2.4.2
> ELF
> 
>   PostgreSQL version (example: PostgreSQL-6.3.2)  :  
> PostgreSQL-7.1beta5
> 
>   Compiler used (example:  gcc 2.7.2)		: gcc 2.95.2
> 
> 
> Please enter a FULL description of your problem:
> ------------------------------------------------
> 1. Configure cannot properly determine Heimdal (0.3d - 0.3e) libs.
> Heimdal has no libk5crypto, all its functions is in libkrb5. Configure
> crashes.
> 2. a) Heimdal has no enc_part2 member in krb5_ticket
>     b) Heimdal has no text member in krb5_error
> 
> 
> 
> Please describe a way to repeat the problem.   Please try to provide a
> concise reproducible example, if at all possible: 
> ----------------------------------------------------------------------
> Install Heimdal-0.3e (in /usr/heimdal for example)
> configure --with-krb5=/usr/heimdal
> make
> 
> 
> 
> 
> If you know how this problem might be fixed, list the solution below:
> ---------------------------------------------------------------------
> It's necessary to make difference in MIT and Heimdal Kerberos
> distributions on configure and build processes with some sort of
> #define HAVE_KRB5_MIT/HEIMDAL. Then it's possible to enclose
> differences in #ifdef ... #endif
> pairs.
> I attached patch which made for me authorization with Heimdal.
> Configure part of this patch is simply hack to make configure work in
> my enviroment. Postgres successfully builds and works.

[ Attachment, skipping... ]


-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  pgman(at)candle(dot)pha(dot)pa(dot)us               |  (610) 853-3000
  +  If your life is a hard drive,     |  830 Blythe Avenue
  +  Christ can be your backup.        |  Drexel Hill, Pennsylvania 19026

In response to

pgsql-bugs by date

Next:From: Peter EisentrautDate: 2001-02-27 17:19:21
Subject: Re: postgresql-7.1beta5 with Heimdal-0.3e
Previous:From: Peter EisentrautDate: 2001-02-27 16:08:41
Subject: Re: postgresql-7.1beta5 configure

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group