Skip site navigation (1) Skip section navigation (2)

Re: Support for QNX6, POSIX IPC and PTHREAD-style locking

From: "Igor Kovalenko" <Igor(dot)Kovalenko(at)motorola(dot)com>
To: "Bruce Momjian" <pgman(at)candle(dot)pha(dot)pa(dot)us>
Cc: <pgsql-patches(at)postgresql(dot)org>
Subject: Re: Support for QNX6, POSIX IPC and PTHREAD-style locking
Date: 2001-11-26 02:39:14
Message-ID: 1f6501c17623$93b79720$20e00518@c773082g (view raw or flat)
Thread:
Lists: pgsql-patches
----- Original Message -----
From: "Bruce Momjian" <pgman(at)candle(dot)pha(dot)pa(dot)us>
To: "Igor Kovalenko" <Igor(dot)Kovalenko(at)motorola(dot)com>
Cc: <pgsql-patches(at)postgresql(dot)org>
Sent: Sunday, November 25, 2001 6:34 PM
Subject: Re: [PATCHES] Support for QNX6, POSIX IPC and PTHREAD-style locking


> > Bruce said he'd accept patch without Posix semaphores. And I asked to
vote
> > 3-way (whole patch, qnx6-support-only or none). What you're saying
appears
> > to be 'none' but you're not making it clear if that's 'no to whole
patch',
> > 'no to posix semaphores', 'no to qnx6-support-only patch' or 'no to
> > anything'.
> >
> > My understanding at this point is, there should not be problem with
applying
> > QNX6-support-only patch, as long as it works within existing framework
and
> > does not introduce non-proven code anywhere. That's what new version of
> > patch is.
>
> I will vote for the QNX-only version.  However, I will not apply any
> patch unless there is agreement from the group.
>
> It is up the group to decide the issue.
>
> However,even though I will vote for the QNX-only version, I am doing
> this only because you feel so strongly something should be in 7.2.  My
> personal opinion is that this entire patch should wait for 7.3.  It is
> very late in 7.2 development and even a reviewed patch of this
> complexity causes more risk than benefit.

Fair enough. I am asking you to get something into 7.2 for practical
reasons. Sooner people will get something, sooner someone will uncover
problems is there are any. That would allow to have reasonable confidence by
the time 7.3 rolled out.

Of course there are betas for such purpose, but people prefer to work with
releases, so I simply want it to have larger exposure. I also want clearer
test case - forcing people to use [potentially unstable] alphas/betas on
QNX6 would distort the picture - if there will be problems it won't be very
clear whether they are related to port or to the base code.

You can mark QNX6 support as 'experimental' if that will help anything.

thanks,
- igor


In response to

Responses

pgsql-patches by date

Next:From: Bruce MomjianDate: 2001-11-26 02:41:52
Subject: Re: Added Encoding
Previous:From: Tatsuo IshiiDate: 2001-11-26 01:58:09
Subject: Re: Added Encoding

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group