Skip site navigation (1) Skip section navigation (2)

v6.4-BETA3 problems with FreeBSD

From: SHIOZAKI Takehiko <takehi-s(at)ascii(dot)co(dot)jp>
To: pgsql-hackers(at)postgresql(dot)org
Subject: v6.4-BETA3 problems with FreeBSD
Date: 1998-10-30 01:09:21
Message-ID: 199810300109.KAA27447@libpc01.pb.ascii.co.jp (view raw or flat)
Thread:
Lists: pgsql-hackers
Hello!

I tried postgresql.v6.4-BETA3 and found some problems especially
with FreeBSD.
The following is my environment:
	FreeBSD 2.2.7-RELEASE
	GNU Make version 3.76.1, by Richard Stallman and Roland McGrath.
	gcc version 2.7.2.1
	GNU Bison version 1.25
	flex version 2.5.4

* makefiles/Makefile.freebsd
	It should have "-Bforcearchive" option just like as
	makefiles/Makefile.bsd (and it used to be).
	Without it, I got such errors in test/regress/results/misc.out.

========================================================================
ERROR:  Can't find function reverse_name in file /usr/local/src/postgresql.v6.4-BETA3/pgsql/src/test/regress/input/../regress.so
========================================================================

	# And the original Makefile.freebsd does not seem to work
	# as you intended.  As `\' overrides `#', the last 2 lines
	# are commented out together.


* Makefile.shlib
	FreeBSD is not supported.
	So no shared library for plpgsql is installed and regression
	test for it fails.

========================================================================
gmake -C src install
gmake[3]: Entering directory `/usr/local/src/postgresql.v6.4-BETA3/pgsql/src/pl/
plpgsql/src'
/usr/bin/install -c -m 644  /usr/local/pgsql/lib/plpgsql.so
usage: install [-CcDps] [-f flags] [-g group] [-m mode] [-o owner] file1 file2
       install [-CcDps] [-f flags] [-g group] [-m mode] [-o owner] file1 ...
             fileN directory
       install -d [-g group] [-m mode] [-o owner] directory ...
gmake[3]: *** [install] Error 64
========================================================================

	And no shared libraries for libecpg, libpq++ and libpq.a
	are made and installed.


* pg_dumpall
	Pg_dumpall command outputs "create database" statement such as:
========================================================================
create database with encoding='EUC_JP' DBNAME;
========================================================================
	But it should be:
========================================================================
create database DBNAME with encoding='EUC_JP';
========================================================================


Regards

-- 
ASCII CORPORATION
Technical Center
SHIOZAKI Takehiko
<takehi-s(at)ascii(dot)co(dot)jp>

Responses

pgsql-hackers by date

Next:From: The Hermit HackerDate: 1998-10-30 02:02:42
Subject: RE: [HACKERS] Open 6.4 items
Previous:From: SHIOZAKI TakehikoDate: 1998-10-30 01:08:54
Subject: relname.data

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group