Alex Hunsaker <badalex(at)gmail(dot)com> writes:
> On Tue, Feb 2, 2010 at 21:38, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
>> Alex Hunsaker <badalex(at)gmail(dot)com> writes:
>>> Yeah the both is gross. How about:
>>> plperl.on_init ?
>> I like the first two. The problem of selecting a good name for the
>> third one is easily solved: don't have it. What would it be except
>> a headache and a likely security problem?
> Well its already in.
Well *that's* easily fixed. I think it's a bad idea, because it's
unclear what you should put there and what the security implications
are. Two entirely separate init strings seems much easier to understand
regards, tom lane
In response to
pgsql-hackers by date
|Next:||From: Joe Conway||Date: 2010-02-03 06:01:13|
|Subject: Re: BUG #5304: psql using conninfo fails in connecting to
|Previous:||From: Alex Hunsaker||Date: 2010-02-03 05:13:06|
|Subject: Re: Add on_trusted_init and on_untrusted_init to plperl UPDATED [PATCH]|