Skip site navigation (1) Skip section navigation (2)

Re: Re: [COMMITTERS] pgsql: Redefine _() to dgettext() instead of gettext() so that it uses

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Alvaro Herrera <alvherre(at)commandprompt(dot)com>
Cc: Hiroshi Saito <z-saito(at)guitar(dot)ocn(dot)ne(dot)jp>, Peter Eisentraut <peter_e(at)gmx(dot)net>, pgsql-hackers(at)postgresql(dot)org
Subject: Re: Re: [COMMITTERS] pgsql: Redefine _() to dgettext() instead of gettext() so that it uses
Date: 2009-03-07 23:06:16
Message-ID: 18969.1236467176@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-committerspgsql-hackers
Alvaro Herrera <alvherre(at)commandprompt(dot)com> writes:
> Understood.  In fact, after having a look at this patch and giving it a
> little refactoring I think it's pretty obvious; right now we're calling
> bind_textdomain_codeset only for the main domain, and with this patch we
> also set it for all other domains we use.

> Does this patch work for you?

Seems like this comment needs to move into the new function:
>   	 * On Windows, we need to explicitly bind gettext to the correct
>   	 * encoding, because gettext() tends to get confused.

More generally, should we push the bindtextdomain calls themselves into
the new function (and perhaps call it something else than
SetDomainCodeSet)?  Seems like logically this should be thought of as
all one operation, ie, it's not clear to me that it ever makes sense to
call bindtextdomain without also worrying about encoding.

			regards, tom lane

In response to

Responses

pgsql-hackers by date

Next:From: Andrew DunstanDate: 2009-03-07 23:51:08
Subject: Re: small parallel restore optimization
Previous:From: Alvaro HerreraDate: 2009-03-07 22:28:09
Subject: Re: Re: [COMMITTERS] pgsql: Redefine _() to dgettext()instead of gettext() so that it uses

pgsql-committers by date

Next:From: Alvaro HerreraDate: 2009-03-07 23:53:39
Subject: Re: Re: [COMMITTERS] pgsql: Redefine _() to dgettext()instead of gettext() so that it uses
Previous:From: Alvaro HerreraDate: 2009-03-07 22:28:09
Subject: Re: Re: [COMMITTERS] pgsql: Redefine _() to dgettext()instead of gettext() so that it uses

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group