Skip site navigation (1) Skip section navigation (2)

Re: 8.3 GSS Issues

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Magnus Hagander <magnus(at)hagander(dot)net>
Cc: "Henry B(dot) Hotz" <hotz(at)jpl(dot)nasa(dot)gov>, pgsql-hackers <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: 8.3 GSS Issues
Date: 2007-10-25 17:22:01
Message-ID: 18658.1193332921@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-hackers
Magnus Hagander <magnus(at)hagander(dot)net> writes:
> On Fri, Oct 19, 2007 at 04:51:04PM -0700, Henry B. Hotz wrote:
>> There's no way to specify the gssapi library to use.  I have three on  
>> my main development Sun:  MIT, Sun, and Heimdal.  I might have more  
>> than one version of one of those three at some times.  Of course  
>> there's no way to specify which kerberos 5 library or openssl library  
>> you want either, so consider this a feature request for future  
>> development.

> Yeah, that's something that can be done for 8.4, certainly not something we
> can put in now. But I'll be happy to see a patch once we open the tree for
> 8.4 :-)

Isn't this something you do by specifying include and link search paths
to configure?  The above argument could be made for *any* library we
use, and I surely do not want to put a single-purpose switch for each
library into configure.

			regards, tom lane

In response to

Responses

pgsql-hackers by date

Next:From: Alvaro HerreraDate: 2007-10-25 17:23:02
Subject: Re: [HACKERS] Re: pgsql: Extract catalog info forerror reporting before an error actually
Previous:From: J. Andrew RogersDate: 2007-10-25 17:21:47
Subject: Re: Opportunity for a Radical Changes in Database Software

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group