Skip site navigation (1) Skip section navigation (2)

Re: Necesito ayuda en la instalción de Psycopg2

From: Marcos Ortiz Valmaseda <mlortiz(at)estudiantes(dot)uci(dot)cu>
To: Mariano Reingart <mariano(at)nsis(dot)com(dot)ar>
Cc: pgsql-es-ayuda(at)postgresql(dot)org, fa sanchez cabo <bikosfa(at)hotmail(dot)com>
Subject: Re: Necesito ayuda en la instalción de Psycopg2
Date: 2009-03-25 20:25:49
Message-ID: 18255284.209321238012749154.JavaMail.root@zimbra2.uci.cu (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Yo trabajo con Python y PostgreSQL también, y me gusta más trabajar con el módulo 
python-pygresql,no he visto éste que dicen ustedes así que no puedo opinar sobre él.
Ahora, si les puedo asegurar que PyGreSQL está fuera de liga.
Lo pueden encontrar en su sitio oficial en http://www.pygresql.org
Actualmente está en la versión 4.0 con muchas mejoras sobre la que está en los repositorios de Debian(pygresql-3.8).
Saludos

P.D: Para el trabajo con bases de datos en Python ,recomiendo el uso de SQLAlchemy, declarado como el mejor ORM (Object Relational Mapper) para Python, además de todas las facilidades que te brinda para el trabajo con SQL.


----- Mensaje original -----
De: "Mariano Reingart" <mariano(at)nsis(dot)com(dot)ar>
Para: "fa sanchez cabo" <bikosfa(at)hotmail(dot)com>
CC: pgsql-es-ayuda(at)postgresql(dot)org
Enviados: Miércoles, 25 de Marzo de 2009 12:49:19 (GMT-0500) Auto-Detected
Asunto: Re: [pgsql-es-ayuda] Necesito ayuda en la  instalción de Psycopg2

Hola, ¿estas instalando manualmente psycopg2 por algun motivo en especial?

En debian podrías instalarlo automáticamente:
apt-get install python-psycopg2

Tenes varios módulos:
python-psycopg2 - Python module for PostgreSQL
python-psycopg2da - Zope database adapter based on python-psycopg2 --
zope3 version
zope-psycopgda2 - Zope database adapter based on python-psycopg2

Cualquier duda avisame
Sds
Mariano

>
> Buenos dias,
>
>
>
>
> He instalado Psycopg 2.0.8 sobre linux (Debian),teniendo en cuenta las
> instrucciones que hay en la red, para primero tener bien instalado el
> paquete mxDateTime, modificando el fichero de configuración para poner los
> path que se correspondían con mi instalación, etc.
> Entonces lo instalo sin que me de problemas utilizando "setup.py build e
> install" coloco la carpeta de ZPyscopgDA en la carpeta de Productos de mi
> instancia Zope.
> Reinicio zope ,pero cuando quiero añadir el Z Pyscopg 2 Database
> Connection, este no me aparece el la lista del ZMI.
> Estoy utilizando, python 2.4.4, Plone3 y Zope 2.10.4.
>
> Alguien puede tener idea si me fala por hacer algo o copiar alguna carpeta
> o fichero en un sitio distinto?
>
> Gracias de antemano.
> _________________________________________________________________
> Descubre todas las formas en que puedes estar en contacto con amigos y
> familiares.
> http://www.microsoft.com/windows/windowslive/default.aspx


--
TIP 10: no uses HTML en tu pregunta, seguro que quien responda no podrá leerlo


-- 




¨¨Tip 9 : Vacumm es tu amigo.......¨¨¨ 
Marcos Ortíz Valmaseda 
Linux User # 418229 
PostgreSQL 8.3.5 && Debian GNU/Linux Experimental User 
Facebook Profile: 
http://www.facebook.com/profile.php?id=1186800712 
My blog: 
http://marcosluis21.wordpress.com 



In response to

pgsql-es-ayuda by date

Next:From: Arturo RossodivitaDate: 2009-03-25 20:34:36
Subject: Re: crear expresion
Previous:From: juanDate: 2009-03-25 18:21:28
Subject: Re: trigger para crear trigger

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group