Skip site navigation (1) Skip section navigation (2)

Re: Migrating between versions. Problem with regexp

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Kaloyan Iliev Iliev <news1(at)faith(dot)digsys(dot)bg>
Cc: pgsql-general(at)postgresql(dot)org
Subject: Re: Migrating between versions. Problem with regexp
Date: 2004-08-29 14:14:53
Message-ID: 17021.1093788893@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-general
Kaloyan Iliev Iliev <news1(at)faith(dot)digsys(dot)bg> writes:
> libvar=# select '\\a\\\\\\.' ~ '\\a\\\\\\.';
> ERROR:  invalid regular expression: invalid escape \ sequence

7.4 and later are stricter about the use of \ than prior versions; see 
http://www.postgresql.org/docs/7.4/static/functions-matching.html#POSIX-ESCAPE-SEQUENCES
You could go back to (approximately) the old behavior by changing
regex_flavor to "extended".

			regards, tom lane

In response to

Responses

pgsql-general by date

Next:From: Kaloyan Iliev IlievDate: 2004-08-29 15:17:13
Subject: Re: Migrating between versions. Problem with regexp
Previous:From: Kaloyan Iliev IlievDate: 2004-08-29 11:14:51
Subject: Migrating between versions. Problem with regexp

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group