Andrew Dunstan <andrew(at)dunslane(dot)net> writes:
> It occurred to me in the dead of the night that instead of:
> ALTER TYPE enumtype ADD 'newlabel'
> it might be better to have:
> ALTER TYPE enumtype ADD LABEL 'newlabel'
> That way if we later wanted to support some other sort of ADD operation
> on types we would be able to more easily.
I can see the point of that, but I don't find LABEL to be a particularly
great name for the elements of an enum type, and so I'm not in favor of
institutionalizing that name in the syntax. How about ADD VALUE?
regards, tom lane
In response to
pgsql-hackers by date
|Next:||From: Brendan Jurd||Date: 2010-10-25 17:20:26|
|Subject: Re: Segfault in 9.0 inlining SRF|
|Previous:||From: Robert Haas||Date: 2010-10-25 17:00:36|
|Subject: Re: Range Types, discrete and/or continuous|