Skip site navigation (1) Skip section navigation (2)

Problèmes UTF8

From: tzacos(at)free(dot)fr
To: pgsql-fr-generale(at)postgresql(dot)org
Subject: Problèmes UTF8
Date: 2011-10-07 11:16:54
Message-ID: 1614843727.2329001317986214191.JavaMail.root@zimbra39-e7.priv.proxad.net (view raw or flat)
Thread:
Lists: pgsql-fr-generale
Bonjour,

j'imagine que je ne dois pas être le premier à poser une question de ce genre. Mais malgré pas mal de recherche je ne trouve pas ma réponse.
Je suis sur postgresql 9.1 installé sur un pc windows XP (pas d'autres choix pour le moment :( ).
j'ai deux bases de données (OGS et OGS2) toutes les deux en Encodage UTF8 dont voici le psql -U postgres -l:


Z:\>psql -U postgres -l
                                      Liste des bases de donnÚes
    Nom    | PropriÚtaire | Encodage |        Tri         |    Type caract.    |     Droits d'acc
-----------+-------------+----------+--------------------+--------------------+-----------------------
 OGS       | ogsadm      | UTF8     | French_France.1252 | French_France.1252 |
 OGS2      | postgres    | UTF8     | C                  | C                  |
 postgres  | postgres    | UTF8     | French_France.1252 | French_France.1252 |
 template0 | postgres    | UTF8     | French_France.1252 | French_France.1252 |=c/postgres          +
           |             |          |                    |                    |postgres=CTc/postgres
 template1 | postgres    | UTF8     | French_France.1252 | French_France.1252 |=c/postgres          +
           |             |          |                    |                    |postgres=CTc/postgres
(5 lignes)


Quand je fait:

pg_dump -f test.sql -s -U postgres OGS2

j'aotient le sql avec les mauvais caractères accentués alors que dans pgadmin3 pas de soucis.

Tous les caractères accentués de mes commentaires apparaissent mal formés (comme dans le tableau ci-dessus)
Même en utilisant l'option -E LATIN1 ca ne donne rien de probant.
De fait, j'ai un script perl qui utilise DBIx::Class::Schema:/Loader dont le résultat ne passe pas correctement les caractères accentués.
aucune des solutions que j'ai pu trouvé ne fonctionne.

Quelqu'un a-t-il une idée?

merci

laurent

Responses

pgsql-fr-generale by date

Next:From: Guillaume LelargeDate: 2011-10-07 12:23:10
Subject: Re: Problèmes UTF8
Previous:From: olivier.arnaudDate: 2011-10-05 15:54:01
Subject: Re: Examples utilisateurs > 2To

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group