Skip site navigation (1) Skip section navigation (2)

Re: Python verison for build in config.pl (Win32)

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Matt <bsg075(at)gmail(dot)com>
Cc: pgsql-novice(at)postgresql(dot)org, pgsql-hackers(at)postgresql(dot)org
Subject: Re: Python verison for build in config.pl (Win32)
Date: 2010-01-20 17:59:31
Message-ID: 15740.1264010371@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-novice
Matt <bsg075(at)gmail(dot)com> writes:
> Attempting to build 8.5 alpha on Windows XP (MSVC 2005) with Python support.
> Path to local interpreter added to config.pl (C:\Python), but message is
> presented:

>   "Could not determine python version from path at build.pl line 38"

> Do the build scripts attempt to determine the Python version from the path
> name? Since my machine has a generic path name, is there a way to specify
> the interpreter version?

Hm, I see this in Mkvcbuild.pm:

        $solution->{options}->{python} =~ /\\Python(\d{2})/i
          || croak "Could not determine python version from path";
        $plpython->AddLibrary($solution->{options}->{python} . "\\Libs\\python$1.lib");

Apparently you need to hack that to deduce the appropriate library
pathname.  What exactly is your python path name, and is it a standard
installation pattern at all?

			regards, tom lane

In response to

Responses

pgsql-novice by date

Next:From: Tom LaneDate: 2010-01-20 18:13:22
Subject: Re: UUID - 8.4.2
Previous:From: Morris, RoyDate: 2010-01-20 17:49:39
Subject: UUID - 8.4.2

pgsql-hackers by date

Next:From: Heikki LinnakangasDate: 2010-01-20 18:00:33
Subject: Synchronization primitives (Was: Re: An example of bugs for Hot Standby)
Previous:From: Leonardo FDate: 2010-01-20 17:48:00
Subject: Re: About "Our CLUSTER implementation is pessimal" patch

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group