Skip site navigation (1) Skip section navigation (2)

Re: [INTERFACES] Error using Perl interface

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: "Mengelbier, Magnus" <Magnus(dot)Mengelbier(at)clinicaldatacare(dot)com>
Cc: pgsql-interfaces(at)postgreSQL(dot)org
Subject: Re: [INTERFACES] Error using Perl interface
Date: 1999-08-17 13:49:35
Message-ID: 15607.934897775@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-interfaces
"Mengelbier, Magnus" <Magnus(dot)Mengelbier(at)clinicaldatacare(dot)com> writes:
> We wonder if anyone has found and resolved an error we recieve when trying
> to connect to a PostgreSQl 6.5.1 database with perl 5.0053.
> We are running Red Hat 6.0 standard installation with PostgreSQL 6.5.1 and
> the perl interface that was available. We opted to install the binaries
> instead of compiliing the source ourselves.  We are running Perl 5.0053 that
> was installed with the system installation.

I believe we found out recently that Perl 5.005-something changed its PM
interfaces, thereby breaking the Postgres perl5 module at both source
and binary levels.  If you revert to Perl 5.004-anything it should work.

It would be nice to find a Perl guru who knows how to fix the perl5
module for the new Perl *without* breaking backwards compatibility for
older Perls (source-level compatibility that is, I suppose binary
compatibility is hopeless).

			regards, tom lane

pgsql-interfaces by date

Next:From: Thomas LockhartDate: 1999-08-17 14:30:26
Subject: Re: [INTERFACES] Error using Perl interface
Previous:From: Ansley, MichaelDate: 1999-08-17 12:17:49
Subject: RE: [INTERFACES] a few additional JDBC points??

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group